New issue
Advanced search Search tips
Note: Color blocks (like or ) mean that a user may not be available. Tooltip shows the reason.
Starred by 51 users

Issue metadata

Status: Duplicate
Owner:
Email to this user bounced
Closed: Dec 2008
Cc:
Components:
EstimatedDays: ----
NextAction: ----
OS: All
Pri: 1
Type: Bug

Restricted
  • Only users with Commit permission may comment.



Sign in to add a comment

Text boxes lose typing

Reported by silk...@gmail.com, Sep 2 2008 Back to list

Issue description

Product Version      : 0.2.149.27 (1583)
URLs (if applicable) : http://www.autohotkey.com/forum/posting.php?
mode=newtopic&f=1 
Other browsers tested: Firefox
Add OK or FAIL after other browsers where you have tested this issue:
Safari 3:
    Firefox 3: OK
IE 7:

What steps will reproduce the problem?
1. Start filling in an issue into the text area
2. Make a correction to the text that has been entered
3.

What is the expected result?
The textbox should always show all the characters that are in the text 
area.

What happens instead?
Some of the characters that are still in the text area are hidden.  They 
blank out and randomly (to me) come back.  They are always still there, but 
they are hidden.

Please provide any additional information below. Attach a screenshot if 
possible.
It's possible that it's specific to Autohotkey's forum, but I highly doubt 
it.  If you'd like to get a Wink video of the issue I can show it no 
problem.
 
[CONFIRMED]

It happens most of the times on username/password fields that the browser 
"remembers".

Comment 2 by Deleted ...@, Sep 3 2008

i also have this problem. using dokuwiki and the textarea field
The proboards.com phpBB forum also has this problem.  The text field appears to lag 
behind the typing, causing some text to disappear as it naturally wraps to the next 
line.   

Comment 4 by dark...@gmail.com, Sep 3 2008

Same behavior in a dokuwiki page modification. Happend more often after a text paste 
in the textarea
I can also confirm this in phpBB forums "Quick-reply".

Comment 6 by Deleted ...@, Sep 4 2008

Same problem with me (winxp home SP3); seems to happen on large text area only (e.g.
Gmail "new mail" one as well as vbulletin ones)
it tends to be 'textarea' asopposed to a form input element of type='text'

MaFt

Comment 8 by aed...@gmail.com, Sep 4 2008

I had problems with dokuwiki and with Wordpress (also since i'm using a BiDi input 
[for Hebrew]). The BiDi could be a separate bug.

Comment 9 by Deleted ...@, Sep 4 2008

Here is a video of it for me: http://screencast.com/t/St9MY0V64EZ .
Also for me same behavior in dokuwiki. If you resize the textarea text will reappear.
I, and several friends, also have had this problem with the textarea of a phpBB 
forum. Seems like just about everywhere else it's working fine.
I've been able to find a minimal reproducible case for this - it seems PHP has a 
TEXTAREA inside a SPAN tag (which is somewhat nonsensical).  Chrome doesn't render 
this properly.  See attached html page.
text_box.html
299 bytes View Download
I can confirm this bug exists as well - and would very much like to fix it (It's a 
hassle editing TWiki documents with Chrome)

Comment 14 by rig9...@gmail.com, Sep 10 2008

>Here is a video of it for me: http://screencast.com/t/St9MY0V64EZ .

That happens for me too on a phpBB forum.

Comment 15 by evan@chromium.org, Sep 10 2008

Labels: -Area-Unknown Area-Compat
Status: Untriaged
Summary: Text boxes lose typing
Thanks for the awesome bug report (with screencast, even) and repro case!

Comment 16 by Deleted ...@, Sep 19 2008

I was just about to report this bug too, but instead I'll just confirm that it also 
happens for me when I try to post replies in a phpbb forum.

The work-around is to highlight all of the text as this will usually correct the 
display.  Sometimes you will also need to do a line break after the last character.

Comment 17 by Deleted ...@, Sep 29 2008

I can also confirm this as a bug on phpBB forums and gmail on Vista + XP SP3.

Comment 18 by ax...@outlook.com, Oct 10 2008

I can also confirm the bug on vBulletin boards using Chrome 0.3.154.0

Comment 19 by nea...@gmail.com, Oct 10 2008

I can confirm the issue on phpBB forums running on forum.unity3d.com using Chrome 0.3.154.0, on XP SP3.
For me there is not always a blinking cursor in text box. Such as when using facebook 
posting a posted items, and typing in  the  description or the comment box.

Comment 21 by hunn...@gmail.com, Oct 20 2008

Actually, this also happens on the Myspace forums too.

The only way i have found to fix this is either wait for a few seconds, or just 
highlight everything.

It also tends to happen whenever a word gets word-wrapped to the next line when 
typing a sentence, part of the word you were typing (the parts before the wrap from 
what i remember) become invisible.

Comment 22 Deleted

Labels: -Mstone-1.0 Mstone-1.1
Status: Available

Comment 24 by vben...@gmail.com, Oct 30 2008

This happens with different revisions of http://www.phpbb.com based forums.

Clicking in the window outside the messed up text box fixes the contents.

These forums are quite popular, and Chrome is getting very low praise from all those 
users.
Changing text-size (ctrl- scroll up and down) fixes the bad rendering too, it's a 
useful fast workaround. Just anything that would 're-render' the current text on 
screen.

Interesting that this textbox is not suffering that problem.


Comment 26 Deleted

Comment 27 by Deleted ...@, Nov 13 2008

Text-areas in Juno webmail had this problem, where an unfinished word reaches the 
right edge of a textarea, and the whole word is wrapped to the second line, and the 
first couple letters disappear.  Moving the mouse cursor and selecting text where the 
letters would have been make the letters visible again.

Comment 28 Deleted

Comment 29 by jdomn...@gmail.com, Nov 20 2008

community server has the same problem with quick reply

Comment 31 by jon@chromium.org, Nov 21 2008

Labels: -Pri-2 -Area-Compat Pri-1 Area-WebKit Usability
Status: Untriaged
Issue reproducible with Chrome 0.4.154.25 on url : 
http://www.autohotkey.com/forum/posting.php?mode=newtopic&f=1

Issue not reproducible on urls : 
http://forum.dokuwiki.org/
http://support.proboards.com/
http://www.vbulletin.com/forum/
http://forums.myspace.com/

Please provide url so as to reproduce the issue.


I can confirm this bug while adding/editing posts on phpBB 2.0.22 boards using Chrome
0.4.154.29.
mixsynth: Please provide url to reproduce the issue.
Any quick reply text box on:
http://forums.mattie.info/cs/forums/

Comment 36 by prog...@gmail.com, Dec 3 2008

confirmed, doesn't always happen but if i try to add characters somewhere between the 
words i already entered... if it doesn't happen at my first try it will happen by the 
4th (each time pointing the caret with the mouse to a new location)

Comment 37 by jon@chromium.org, Dec 3 2008

Mergedinto: 3811
Status: Duplicate
I believe this is fixed in the nightly builds.  It would help a lot if someone could 
download the nightly build from http://build.chromium.org/buildbot/continuous/LATEST/ 
and try it to see if the problem is resolved.

Comment 38 by Deleted ...@, Dec 4 2008

I can confirm that the nightly build of 0.5.155.0 works fine for large textareas in 
twiki.
Build 0.5.155.0 works for me in dokuwiki.

Comment 40 by Deleted ...@, Dec 12 2008

I still have the same prob on phpBB forums. Using Chrome 1.0.

Comment 41 by nea...@gmail.com, Dec 12 2008

Still happens on phpBB forums (forum.unity3d.com, the posting message text area). 
Chrome 1.0.154.36.
Works fine in latest build
I'm using Google Chrome 0.4.154.33 and still suffer from this problem on various 
phpbb forums.
But I can report that Chromium 1.0.155.0 (6968) doesn't suffer from this bug.

Comment 45 by Deleted ...@, Dec 16 2008

Happens on multiple sites with multiline text box:
Chrome 1.0.154.36
Windows XP SP3
Workaround: minimizing and maximizing Chrome window.

Please release the fix ASAP as it is extremely annoying.

Comment 46 by mixsy...@gmail.com, Dec 18 2008

Update: this bug also applies to (at least some) center-justified <input> elements. 
Go to www.surfthechannel.com and type some text into the 'search' box at the top; it 
doesn't display properly until you click outside the box. (Still on Chrome 
1.0.154.36.)

@ #34: I can't refer you to the exact forum I'm looking at because it's members only. 
It seems apparent from the above comments that all phpBB installations are equally 
affected.

Comment 47 by jon@chromium.org, Dec 23 2008

Labels: Regression stable

Comment 48 by jon@chromium.org, Dec 23 2008

Labels: -Regression -stable

Comment 49 by mixsy...@gmail.com, Dec 29 2008

Update: this bug also applies to some conventional left-justified <input> elements.

Example:
1) Go to www.youtube.com.
2) Type something into the main "search" box at the top.
3) Click anywhere in the middle of the text you just entered and try typing some 
more.
4) The text you insert overwrites the text already in the box until you click outside 
the box or scroll the page up or down.

Still using Chrome 1.0.154.36 on Vista Home Premium.

Comment 50 by mixsy...@gmail.com, Dec 30 2008

Update: I can confirm that this bug is FIXED in the latest nightly builds of 
Chromium, so should be fixed in the next Chrome update. I'm currently running 
Chromium 1.0.156.0 (7477).
Great, thanks.

Comment 52 by Deleted ...@, Jan 16 2009

Hi mixsynth :), just want to ask where did you get 1.0.156 from??

i just downloaded and installed chrome and still getting this problem.
the version of chrome is 1.0.154.43, and chrome's telling me my version is up to 
date.

Comment 53 Deleted

reynardktli: nightly builds such as 1.0.156 are unstable intermediate builds not 
publicly released. You can download one from 
http://build.chromium.org/buildbot/snapshots/chromium-rel-xp/

For unstable builds with a bit more QA, switch to the dev channel, currently at 
2.0.157.0, at http://dev.chromium.org/getting-involved/dev-channel - the bug remains 
fixed in the current dev build.

Comment 55 by oracl...@gmail.com, Feb 19 2009

i'm using chrome build 1.0.154.48 and this bug still exists on surfthechannel.com 
search field.

Comment 56 by jon@chromium.org, Feb 19 2009

This bug will be fixed in 2.x releases.  The fix is not being ported back to 1.x.  
Don't fear, we are not going to take a year to go from 1.x to 2.x.  If you want the 
fix now you should switch to the dev channel.

Comment 57 by Deleted ...@, Jul 16 2009

I have a similar issue with a text input control. The control still have a focus, but
when you type, nothing is entered. If I click the left mouse button on it and hold it
and then type, it enters the text.

Also, the control has the yellow border arround it, which indicates it has a focus.

Comment 58 by prog...@gmail.com, Jul 16 2009

@vitmalina
this issue was fixed a long time ago

please open a new issue and include the problematic URL or (preferably) if possible 
upload a reduced case
Labels: -Usability bulkmove Type-Usability
Mergedinto:
Product Version      : 0.2.149.27 (1583)
URLs (if applicable) : http://www.autohotkey.com/forum/posting.php?
mode=newtopic&amp;f=1 
Other browsers tested: Firefox
Add OK or FAIL after other browsers where you have tested this issue:
Safari 3:
    Firefox 3: OK
IE 7:

What steps will reproduce the problem?
1. Start filling in an issue into the text area
2. Make a correction to the text that has been entered
3.

What is the expected result?
The textbox should always show all the characters that are in the text 
area.

What happens instead?
Some of the characters that are still in the text area are hidden.  They 
blank out and randomly (to me) come back.  They are always still there, but 
they are hidden.

Please provide any additional information below. Attach a screenshot if 
possible.
It's possible that it's specific to Autohotkey's forum, but I highly doubt 
it.  If you'd like to get a Wink video of the issue I can show it no 
problem.
Project Member

Comment 60 by bugdroid1@chromium.org, Oct 13 2012

Labels: Restrict-AddIssueComment-Commit
This issue has been closed for some time. No one will pay attention to new comments.
If you are seeing this bug or have new data, please click New Issue to start a new bug.
Project Member

Comment 61 by bugdroid1@chromium.org, Mar 10 2013

Labels: -Area-WebKit -Type-Usability Cr-Content Cr-UI-Usability Type-Bug
Project Member

Comment 62 by bugdroid1@chromium.org, Apr 6 2013

Labels: -Cr-Content Cr-Blink

Sign in to add a comment