New issue
Advanced search Search tips
Note: Color blocks (like or ) mean that a user may not be available. Tooltip shows the reason.

Issue 112706 link

Starred by 4 users

Issue metadata

Status: Verified
Owner:
User never visited
Closed: Mar 2012
Cc:
Components:
EstimatedDays: ----
NextAction: ----
OS: All
Pri: 1
Type: Bug-Regression

Restricted
  • Only users with EditIssue permission may comment.



Sign in to add a comment

Font settings aren't saved on quit

Reported by paulpmi...@gmail.com, Feb 4 2012

Issue description

Chrome Version       : 18.0.1025.3
OS Version: OS X 10.7.3

What steps will reproduce the problem?
1. Open settings -> advanced settings -> go to fonts,
2. Change fixed font to something else (for example, "Menlo").
3. Restart chrome.

What is the expected result?
Font is changed to "Menlo".

What happens instead?
Fixed-width font wasn't changed.

UserAgentString: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_7_3) AppleWebKit/535.19 (KHTML, like Gecko) Chrome/18.0.1025.3 Safari/535.19
 

Comment 1 by tkent@chromium.org, Feb 6 2012

Labels: Feature-Options
Cc: csilv@chromium.org
Labels: -Area-Undefined Area-UI
Can't repro on Linux trunk or Mac canary.  Chris, can you try to repro?
I'm an issue starter and the bug is fixed in canary for me. So this can be closed.
Status: WontFix
Thanks.
This happen on Windows canary now. Fonts can be changed as normal within the session, but the changes won't be remembered after closing browser.

Comment 6 by csilv@chromium.org, Feb 9 2012

Status: Available
Summary: Font setting (font size) isn't saved on quit
I'm able to partially reproduce this issue.  On both Mac Canary and Win Canary, the 'font size' preference is not saving to disk.  ie, change the font setting to 'small', or 'large', and then exit and relaunch.  The font size setting will remain what it was.

However, changing the font inside the 'Customize fonts' dialog is working fine, for me on both platforms.  So that contradicts the first message.

I'm going to re-open this issue based on these findings.
In my preferences file, last lines seem to have duplicates.

   "webkit": {
      "webprefs": {
         "default_fixed_font_size": 13,
         "default_font_size": 16,
         "fixed_font_family": "Larabiefont Rg",
         "global": {
            "default_fixed_font_size": 13,
            "default_font_size": 16,
            "fixed_font_family": "Larabiefont Rg",
            "minimum_font_size": 10,
            "minimum_logical_font_size": 10,
            "sansserif_font_family": "Microsoft JhengHei",
            "serif_font_family": "Bitstream Cyberbit",
            "standard_font_family": "YOzFontN"
         },
         "minimum_font_size": 10,
         "minimum_logical_font_size": 10,
         "sansserif_font_family": "Microsoft JhengHei",
         "serif_font_family": "Bitstream Cyberbit",
         "standard_font_family": "YOzFontNM",
         "uses_universal_detector": false

YOzFontNM is my previous choice, while YOzFontN is my current setting. As pasted here, the change does write into preferences file during the session. However after closing browser both standard_font_family lines will back to the same previous YOzFontNM.
Sorry, correction. The change will retain after closing browser, but reverted next time I start browser.

Comment 9 by csilv@chromium.org, Feb 10 2012

Labels: -OS-Mac OS-All Mstone-19
Owner: csilv@chromium.org
Status: Assigned
Thanks innaterebel, your information is helpful, I think I have an idea where I need to look.

FYI fresh profile does not reproduce and does not have those duplicate lines. Bug may be rooted in certain past versions. And I didn't do anything else about font recently besides changing that one font. Thank you.
I was seeing this problem in the google-chrome-beta channel (18.0.1025.39-122785) on Fedora 16, even after moving all my configuration out of the way.  I would change the monospace font, and it would change, but the next time I opened chrome it would be back to the previous setting.  I've worked around this by installing the -stable version (17.0.963.56-121963) temporarily, changing the font setting there, and then moving back to the beta.
Duplicate emerge:  issue 116361 .
 Issue 116361  has been merged into this issue.

Comment 14 by csilv@chromium.org, Mar 20 2012

Cc: mnaga...@chromium.org
Mikhail,

This issue seems to be caused by your work in preferences.  I can easily duplicate the bug.  Current builds of Canary read in the old preference, but write the new one without removing the old.  I'm starting to investigate this, but please let me know if you know where the problem might be.

Comment 15 by csilv@chromium.org, Mar 20 2012

Status: Started
I have a pending fix...

Comment 16 by dhw@chromium.org, Mar 20 2012

> Mikhail, This issue seems to be caused by your work in preferences. 

Is this a Regression bug then?

Comment 17 by csilv@chromium.org, Mar 20 2012

Cc: karen@chromium.org
dhw, yes it is, it is currently in both M18 and M19.  The fix is a one-line fix.  I will mark this for merge consideration once I have the fix on trunk.
Project Member

Comment 18 by bugdroid1@chromium.org, Mar 20 2012

The following revision refers to this bug:
    http://src.chromium.org/viewvc/chrome?view=rev&revision=127707

------------------------------------------------------------------------
r127707 | csilv@chromium.org | Tue Mar 20 09:55:38 PDT 2012

Changed paths:
 M http://src.chromium.org/viewvc/chrome/trunk/src/chrome/browser/ui/prefs/prefs_tab_helper.cc?r1=127707&r2=127706&pathrev=127707

Fix prefs migration for font settings.

BUG= 112706 
TEST=Verify font changes work when old preference values exist. See bug for details.
Review URL: https://chromiumcodereview.appspot.com/9749001
------------------------------------------------------------------------

Comment 19 by csilv@chromium.org, Mar 20 2012

Labels: -Mstone-19 Mstone-18 Merge-Requested
Summary: Font settings aren't saved on quit
Karen, this issue is fixed on trunk and I am requesting merge to M18 to fix a regression.

Comment 20 by dhw@chromium.org, Mar 20 2012

Labels: -Pri-2 -Type-Bug Pri-1 Type-Regression
Confirm fixed in 19.0.1076.0 canary. Thanks for investigation!

Comment 22 by kareng@google.com, Mar 23 2012

Labels: -Merge-Requested Merge-Merged
landed on 1025

Comment 23 by kareng@google.com, Mar 23 2012

landed on 1025
Project Member

Comment 24 by bugdroid1@chromium.org, Mar 23 2012

Labels: merge-merged-1025
The following revision refers to this bug:
    http://src.chromium.org/viewvc/chrome?view=rev&revision=128587

------------------------------------------------------------------------
r128587 | karen@chromium.org | Fri Mar 23 15:07:46 PDT 2012

Changed paths:
 M http://src.chromium.org/viewvc/chrome/branches/1025/src/chrome/browser/ui/prefs/prefs_tab_helper.cc?r1=128587&r2=128586&pathrev=128587

Merge 127707 - Fix prefs migration for font settings.

BUG= 112706 
TEST=Verify font changes work when old preference values exist. See bug for details.
Review URL: https://chromiumcodereview.appspot.com/9749001

TBR=csilv@chromium.org
Review URL: https://chromiumcodereview.appspot.com/9834068
------------------------------------------------------------------------
Working fine with 18.0.1025.140 (Official Build 128625) on Mac 10.7.3,Linux 64bit and Windows 7. 
Working fine on Chrome OS also.

Comment 27 Deleted

Status: Verified
Verified as fixed on all OS with 18.0.1025.140 (Official Build 128625)
Project Member

Comment 29 by bugdroid1@chromium.org, Oct 13 2012

Labels: Restrict-AddIssueComment-Commit
This issue has been closed for some time. No one will pay attention to new comments.
If you are seeing this bug or have new data, please click New Issue to start a new bug.
Labels: -Feature-Options Feature-Settings
Project Member

Comment 31 by bugdroid1@chromium.org, Mar 9 2013

Labels: -Area-UI -Type-Regression -Mstone-18 -Feature-Settings Type-Bug-Regression Cr-UI-Settings Cr-UI M-18
Project Member

Comment 32 by bugdroid1@chromium.org, Mar 13 2013

Labels: -Restrict-AddIssueComment-Commit Restrict-AddIssueComment-EditIssue

Sign in to add a comment