New issue
Advanced search Search tips
Note: Color blocks (like or ) mean that a user may not be available. Tooltip shows the reason.

Issue 111474 link

Starred by 19 users

Issue metadata

Status: Archived
Owner:
Closed: Feb 2015
Cc:
Components:
EstimatedDays: ----
NextAction: ----
OS: ----
Pri: 2
Type: Bug



Sign in to add a comment

Error 7 (net::ERR_TIMED_OUT): The operation timed out.

Reported by d.and.dw...@gmail.com, Jan 26 2012

Issue description

Chrome Version       : 16.0.912.77
URLs (if applicable) : All URLs
Other browsers tested:
Add OK or FAIL after other browsers where you have tested this issue:
Safari 5:
Firefox 4.x:
       IE 7/8/9:OK 

What steps will reproduce the problem?
1.Open chrome and use 4-6 tabs. After few minutes the I get the Error 7 (net::ERR_TIMED_OUT): The operation timed out. in some or all tabs. 

2.As it seems the Chrome having problems loading pages – It take too much time until it give up. I try the WiFi and lan connection and I get same results (in different networks). In addition I clean the cookies and the cash – But it didn’t help. 
3.

What is the expected result?
Since I am using chrome for few years now this seems like a new bug. I try the Internet explorer 9 and don’t ass that problem.


What happens instead?


Please provide any additional information below. Attach a screenshot if
possible.

 
Labels: -Area-Undefined Area-Internals Internals-Network
Please follow http://www.chromium.org/for-testers/providing-network-details
Labels: Action-FeedbackNeeded
From dump 4adc2249-7663-4b98-9d10-bc06d7966673:

There is no ERR_TIMED_OUT logged here. All URLRequests completed fine... there are some  network change notifications (and proxy changes) at the beginning of th elog (the passive part of it), but those events happened before net-internals stared active logging.

Make sure net-internals is open before the other tabs.
Labels: -Internals-Network -Action-FeedbackNeeded Internals-Network-HTTP
Status: Untriaged
Event 10789: We basically pick a socket that has been idle for 77 seconds. There is no response from that socket so we timeout 24 seconds later.

Sounds like a problem with the socket pool.

5335: SOCKET
finapi.themarker.com:80
Start Time: Fri Jan 27 2012 13:29:49 GMT-0800 (Pacific Standard Time)

t=1327699789468 [st=     0] +SOCKET_ALIVE  [dt=104354]
                             --> source_dependency = 5264 (CONNECT_JOB)
t=1327699789468 [st=     0]   +TCP_CONNECT  [dt=81]
                               --> address_list = ["94.127.73.80:80"]
t=1327699789468 [st=     0]      TCP_CONNECT_ATTEMPT  [dt=81]
                                 --> address = "94.127.73.80:80"
t=1327699789549 [st=    81]   -TCP_CONNECT
                               --> source address = "192.168.14.170:57744"
t=1327699789869 [st=   401]   +SOCKET_IN_USE  [dt=15]
                               --> source_dependency = 5547 (HTTP_STREAM_JOB)
t=1327699789870 [st=   402]      SOCKET_BYTES_SENT
                                 --> byte_count = 408
t=1327699789883 [st=   415]      SOCKET_BYTES_RECEIVED
                                 --> byte_count = 778
t=1327699789884 [st=   416]   -SOCKET_IN_USE
t=1327699791852 [st=  2384]   +SOCKET_IN_USE  [dt=203]
                               --> source_dependency = 7175 (HTTP_STREAM_JOB)
t=1327699791852 [st=  2384]      SOCKET_BYTES_SENT
                                 --> byte_count = 619
t=1327699792054 [st=  2586]      SOCKET_BYTES_RECEIVED
                                 --> byte_count = 758
t=1327699792055 [st=  2587]   -SOCKET_IN_USE
t=1327699792156 [st=  2688]   +SOCKET_IN_USE  [dt=170]
                               --> source_dependency = 7458 (HTTP_STREAM_JOB)
t=1327699792157 [st=  2689]      SOCKET_BYTES_SENT
                                 --> byte_count = 699
t=1327699792321 [st=  2853]      SOCKET_BYTES_RECEIVED
                                 --> byte_count = 4096
t=1327699792325 [st=  2857]      SOCKET_BYTES_RECEIVED
                                 --> byte_count = 280
t=1327699792326 [st=  2858]   -SOCKET_IN_USE
t=1327699869877 [st= 80409]   +SOCKET_IN_USE  [dt=23945]
                               --> source_dependency = 10792 (HTTP_STREAM_JOB)
t=1327699869877 [st= 80409]      SOCKET_BYTES_SENT
                                 --> byte_count = 681
t=1327699893822 [st=104354]   -SOCKET_IN_USE
t=1327699893822 [st=104354] -SOCKET_ALIVE
10789: URL_REQUEST
http://finapi.themarker.com/tmfinapi/q?rm=m&cb=TM.BarMedadim.parseReply&enc=utf-8&qm=ibg
Start Time: Fri Jan 27 2012 13:31:09 GMT-0800 (Pacific Standard Time)

t=1327699869875 [st=    0] +REQUEST_ALIVE  [dt=23947]
t=1327699869875 [st=    0]   +URL_REQUEST_START_JOB  [dt=23947]
                              --> load_flags = 65536 (VERIFY_EV_CERT)
                              --> method = "GET"
                              --> priority = 1
                              --> url = "http://finapi.themarker.com/tmfinapi/q?rm=m&cb=TM.BarMedadim.parseReply&enc=utf-8&qm=ibg"
t=1327699869876 [st=    1]      HTTP_CACHE_GET_BACKEND  [dt=0]
t=1327699869876 [st=    1]      HTTP_CACHE_OPEN_ENTRY  [dt=0]
t=1327699869876 [st=    1]      HTTP_CACHE_ADD_TO_ENTRY  [dt=0]
t=1327699869876 [st=    1]      HTTP_CACHE_READ_INFO  [dt=1]
t=1327699869877 [st=    2]     +HTTP_STREAM_REQUEST  [dt=0]
t=1327699869877 [st=    2]        HTTP_STREAM_REQUEST_BOUND_TO_JOB
                                  --> source_dependency = 10792 (HTTP_STREAM_JOB)
t=1327699869877 [st=    2]     -HTTP_STREAM_REQUEST
t=1327699869877 [st=    2]     +HTTP_TRANSACTION_SEND_REQUEST  [dt=0]
t=1327699869877 [st=    2]        HTTP_TRANSACTION_SEND_REQUEST_HEADERS
                                  --> GET /tmfinapi/q?rm=m&cb=TM.BarMedadim.parseReply&enc=utf-8&qm=ibg HTTP/1.1
                                      Host: finapi.themarker.com
                                      Connection: keep-alive
                                      User-Agent: Mozilla/5.0 (Windows NT 6.1) AppleWebKit/535.7 (KHTML, like Gecko) Chrome/16.0.912.77 Safari/535.7
                                      Accept: */*
                                      Referer: http://www.themarker.com/
                                      Accept-Encoding: gzip,deflate,sdch
                                      Accept-Language: en-US,en;q=0.8
                                      Accept-Charset: ISO-8859-1,utf-8;q=0.7,*;q=0.3
                                      Cookie: [value was stripped]
t=1327699869877 [st=    2]     -HTTP_TRANSACTION_SEND_REQUEST
t=1327699869877 [st=    2]     +HTTP_TRANSACTION_READ_HEADERS  [dt=23945]
t=1327699869877 [st=    2]        HTTP_STREAM_PARSER_READ_HEADERS  [dt=23945]
                                  --> net_error = -7 (TIMED_OUT)
t=1327699893822 [st=23947]     -HTTP_TRANSACTION_READ_HEADERS
                                --> net_error = -7 (TIMED_OUT)
t=1327699893822 [st=23947]   -URL_REQUEST_START_JOB
                              --> net_error = -7 (TIMED_OUT)
t=1327699893822 [st=23947] -REQUEST_ALIVE
                            --> net_error = -7 (TIMED_OUT)
10792: HTTP_STREAM_JOB
http://finapi.themarker.com/
Start Time: Fri Jan 27 2012 13:31:09 GMT-0800 (Pacific Standard Time)

t=1327699869877 [st=0] +HTTP_STREAM_JOB  [dt=0]
                        --> original_url = "http://finapi.themarker.com/"
                        --> url = "http://finapi.themarker.com/"
t=1327699869877 [st=0]   +PROXY_SERVICE  [dt=0]
t=1327699869877 [st=0]      PROXY_SERVICE_RESOLVED_PROXY_LIST
                            --> pac_string = "DIRECT"
t=1327699869877 [st=0]   -PROXY_SERVICE
t=1327699869877 [st=0]    TCP_CLIENT_SOCKET_POOL_REQUESTED_SOCKET
                          --> host_and_port = "finapi.themarker.com:80"
t=1327699869877 [st=0]   +SOCKET_POOL  [dt=0]
t=1327699869877 [st=0]      SOCKET_POOL_REUSED_AN_EXISTING_SOCKET
                            --> idle_ms = 77551
t=1327699869877 [st=0]      SOCKET_POOL_BOUND_TO_SOCKET
                            --> source_dependency = 5335 (SOCKET)
t=1327699869877 [st=0]   -SOCKET_POOL
t=1327699869877 [st=0] -HTTP_STREAM_JOB
log.zip
1.4 MB Download

Comment 4 by mmenke@chromium.org, Jan 30 2012

The retry logic only triggers on ERR_CONNECTION_RESET, ERR_CONNECTION_CLOSED, ERR_CONNECTION_ABORTED, and ERR_SOCKET_NOT_CONNECTED (See http_network_transaction.cc).  I believe sockets generally shouldn't timeout unless there's a connection issue of some sort, rather than just as a result of reusing a stale socket.

Comment 5 by wtc@chromium.org, Feb 6 2012

Cc: willchan@chromium.org wtc@chromium.org eroman@chromium.org
Labels: Mstone-19
Owner: mmenke@chromium.org
Status: Assigned
Dear Matt,
 
Can you please let me know what is the status of this bug? I sow you assigned the bug??
In any case, I can’t use the chrome due to this bug. So, I moved to IE9 :-(
 
Do you think un-installing / installing can help ? any other solution ?

IN ANY CASE THIS IS NOT A CONNECTION PROBLEM!!
 
Regards,
Dudi

Comment 7 by Deleted ...@, Feb 20 2012

Hello,

I´ve got the same issue here with cool novo 2.0.0.9 (formerly known as ChromePlus).
IE9 works fine, so I don´t think this is a network or connection problem.

Regards,
Jens
08e24614-45a1-41a9-b2fd-94e13d2e61bd
425 KB View Download

Comment 8 by Deleted ...@, Feb 20 2012

PS: If I press ESC or the X to stop the current operation an immediately load the same page again it works instantly.
We ´ve got a very fast connection here with 100down/5up MBit and a second computer with chrome doesn´t have this issue.

But therefor all of my computers and notebooks with coolnovo which are synchronized have the same issue here at home and in my office.

Regards,
Jens

Comment 9 by mmenke@google.com, Feb 21 2012

schnellerundbesser:  Could you try Chrome or Chromium and make sure you get the same error?  I have no idea if cool novo's network stack is any different from Chrome's.

Comment 10 by Deleted ...@, Feb 22 2012

I have similar issues, 17.0.963.56, just on https pages. First visit to a new https will nearly always time out with this error, immediate reload always works. Browser session stays up days at a time and doesn't seem related. FWIW I haven't observed this on the mac. Prediction service/predict network actions are both off.
marcreichman:  Could you follow the instructions here:  http://www.chromium.org/for-testers/providing-network-details and post a dump file of the error occurring?  Note that net-internals must be open before you reproduce the error, to get a full log dump.

Also, could you try temporarily disabling your firewall/anti-virus and see if that fixes the problem?  The difference across platforms makes me suspicious of third party programs, though could certainly be something else.

You could also try disabling SSL false start (Run from the command line with --disable-ssl-false-start).  False start can be responsible for SSL-only issues, but it generally causes problems only with very specific sites, and then it typically causes other errors (empty response, possible connection closed), but I suppose it could still be the problem you're running into.

Comment 12 by Deleted ...@, Feb 22 2012

Of course when I have that on I can't reproduce it. Very frustrating! I will try to get a reproducible case. No AV, no firewall.

Comment 13 by Deleted ...@, Feb 22 2012

I have tried to reproduce this condition with the recording on. When i have it on every single https site I try loads perfectly first try. Is it at all possible that the recording is changing anything?
I've never run into that before, but it's theoretically possible.  Logging may slow things down very slightly, so errors that depend on very tight timing can theoretically disappear.

Does having net-internals closed, and running Chrome with --disable-ssl-false-start also seem to resolve the issue?

If not, I'll file a new bug for your issue and pass it along to the SSL people.  If so...  Probably still worth passing along to them, as it sounds like you're running into it on a bunch of sites, which is unusual.

Comment 15 by Deleted ...@, Feb 22 2012

I will run with that option and report back if I see the issue show up again.

Comment 16 by Deleted ...@, Feb 23 2012

Just FYI, I have seen this problem twice today with the ssl option set. Just to be certain I went to chrome://version and copied this:
"C:\Users\mreichman\AppData\Local\Google\Chrome\Application\chrome.exe" --disable-ssl-false-start --flag-switches-begin --enable-print-preview --flag-switches-end"

Will try again with the logging on.

Comment 17 by Deleted ...@, Feb 23 2012

Finally got it to happen with the logging on. Attached.
76896c34-d66d-46e8-a6ea-7e0c787e3a92
2.4 MB View Download

Comment 18 by Deleted ...@, Mar 3 2012

Reply to mmenke@google.com, Feb 21, 2012:

Seems to be the CoolNovo / ChromePlus version. With chrome I had the error one or two times but this could had have another reason. 
With CoolNovo 2.1.40 which came out recently the error didn´t appear anymore as far as I can say for now.
Labels: -Mstone-19 Mstone-20
Still have not had time to look at this again, punting.

Comment 20 by Deleted ...@, Apr 4 2012

Still happening as of 18.0.1025.142, 4/4.

Comment 21 by Deleted ...@, Apr 18 2012

Still happening as of 18.0.1025.162
I apologize for taking so long to get back to this.

marcreichman:  Looks like linked-in is never responding after we try to negotiate an SSL connection.

marcreichman, Arra.Aravindhan:  Is it only happening to SSL sites?  If so, it's an entirely different issue from what the original bug reporter was reporting, and we should have a new bug report for the issue.

Comment 23 by Deleted ...@, Apr 18 2012

mmenke, definitely only on SSL sites. I apologize if I missed the original ticket intention. Can you open up a new bug and attach my logs?

In that case it was linked in but this happens to be more than once a day on this particular installation, always SSL, but different sites. Generally on first visits.
I've filed a new bug for the problem ( Issue 124048 ).  Thanks for the reports.

Comment 25 by Deleted ...@, Apr 28 2012

My computer is 32 bit vista--Dimension C521 Home Premium. The options to run Chrome in  is NOT on my computer at all!!!! Do you know what I can do? I play Cityville and it plays Ok, on my home page of the game but the second I go to visit someones page it Freezes and crashes. Chrome does NOT play good on other apps either. I get an error message either mins after download or hrs. I don't know the yr of my computer, would you know that? I can ONLY play for a little of cafeworld on IE9 But Can't play Cityville on IE9 at all!!!! Do I have to BUY a special Browser just to be able to get my computer to play these games normal?

Comment 26 Deleted

Comment 27 by Deleted ...@, Apr 28 2012

Also....When I run Firefox it ONLY lets me play cafeworld and crashes sec and mins after downloading adobe flash and quicktime. Thanks in advance for your help!! Please email me a/s/a/p.. ginadoggies@gmail.com Gina 
Labels: -Mstone-20 Mstone-21
Punting this issue.

Comment 29 Deleted

Still happens in chrome 18.0.1025.168 (Official Build 134367)
Error happens more often with multiple tabs. Not just with SSL sites, also with plain http sites. Reinstall of Chrome did not help. No AV or perfonal firewall is installed (except of default Windows 7 32bit).

Question is whether is this network issue or starting new tab in background issue (not necessary network related - starting process or some internal structures locking). It is more probable to trigger the bug when opening multiple links in background tabs.
Labels: -Mstone-21 Mstone-22
Hi i have encountered the same problem. The problem "Error 7 (net::ERR_TIMED_OUT): The operation timed out." is encountered when I access https://www.bdo.com.ph/ 

I'm using Ubuntu 12.04 and Google chrome is Version 20.0.1132.57.

I don't have problem accessing the website in our office.

Please see attached logs. Please let me know other information I need to provide to fix this issue.

Thanks. :)
Error-7-net-internals-log.json
70.9 KB View Download
Labels: Internals-Network-SSL
We should rename this bug so it's not so generic. In any case, the issue in comment 32 sounds like it's possibly a SSL issue. I just tested and got ERR_CONNECTION_REFUSED with that website.

Comment 34 by agl@chromium.org, Jul 18 2012

amdrill_bautista: www.bdo.com.ph doesn't serve HTTPS, so it's not expected to work. However, you're clearly seeing a timeout when you should get a fast connection refused. But I'm afraid that this isn't a Chrome problem - it looks like the TCP RSTs are getting filtered somewhere along the line.


I can access the website: https://www.bdo.com.ph/ , using google Crome and Internet Explorer here in our office. By the way im here in the Philippines.

Comment 36 by agl@chromium.org, Jul 18 2012

www.bdo.com.ph may be filtering connections, possibly on a national basis. That could also explain why you're seeing timeouts from another location. However, if they're doing tricks like that then there's nothing we can do I'm afraid. From the US, all IP addresses for www.bdo.com.ph have port 443 closed.
I get this exact error in Google chrome version 20.0.1132.57 m. It happens on any random sites whether https or http etc! Doing online purchases is a risk with this bug!
It looks like the timeout error affects certain types of sites only, for me at least. Out of 10 refreshes of the browser for http://www.bbc.co.uk/news/ I get no timeout errors but on the 3rd successive browser refresh for http://forums.bethsoft.com/forum/33-fallout-3-general-discussion/ I get a timeout error. I get the same error on other sites also I just noticed that it affects some types of sites for some reason.

Comment 39 by Deleted ...@, Aug 10 2012

We are a company that promotes the use of Chrome with our sites. However as of late we have been seeing many complaints from our users that they are receiving this error as well. We would like to continue to promote using the browser to our 5 million users however a solution would be very helpful. Here is a recent Screen shot. 
ATT3335663.png
88.7 KB View Download
Is it possible this could be an extension related problem?

Comment 41 by tarap...@gmail.com, Aug 13 2012

- It is not extension related (bug occures also on clean installation with no extensions)

- It is not SSL related, bug occures on http sites as well

- It is not network releated - bug occures on stable optical internet connection. No other software has network errors.

Comment 42 by agl@chromium.org, Aug 13 2012

tarapcik: we would need reproduction steps or a net-internals log (http://www.chromium.org/for-testers/providing-network-details) in order to investigate this.

Comment 43 by Deleted ...@, Aug 14 2012

I have the same issue.

This is a net-internals log when trying to load youtube.

I only get the error sometimes when refreshing the site.
net-internals-log (3).json
117 KB View Download

Comment 44 by agl@chromium.org, Aug 14 2012

Francis.S.Li: if you refresh after getting the time out, does it work immediately?

It looks like Chrome was running for a while before the net-internals log starts because I can't see the connection to youtube occuring. But I'm wondering whether a NAT box in the network (i.e. a home router, or possibly something at an ISP) is timing out the connection and dropping all packets after a while. From Chrome's point of view it's doing nothing wrong: it wrote the request to the network and never got a reply.
Hrmm that's an interesting point about the NAT box. I just did a random off-the-cuff test but so far I only experience this in nat'd environments.
I had this exact problem and solved it by replacing my router.

The problem I was having was:

- I would frequently, but not consistently, get Error 7: net::ERROR_TIMED_OUT errors. (the same as in the screenshot attached by paulajpe...@gmail.com above).

- The errors would most often happen on the same sites:  Youtube, gmail, many of the google-app sites (this one, Google groups, Google maps, etc.  Facebook would mostly work, but attempting to expand conversations would often fail.  I never had problems with most sites (Reddit, Slashdot, Google search, etc).  

- Some sites failed more constantly than others.  Gmail and Google Groups were almost unusable.  Youtube would fail only 10-20% of the time.

- Once a site failed, it would consistently fail if I tried to re-load the site -- either by hitting refresh, or by opening the same link in a new tab.  I would always have to wait awhile (maybe 30-60 seconds?) and try again, and it would often start working.
 
- If the site failed in Chrome but I immediately opened the same site it in a new browser, it would usually work.  This made me assume the issue was Chrome.  (Later I switched over to Firefox, and found the issue was still happening.  I didn't keep using Firefox, so I'm not sure if it happened more or less often)

- If the site failed and I immediately opened the site in a new incognito window, the site would usually work.

- If the site failed and I immediately cleared the cache and refreshed the page, the site would usually work.

- If I managed to load the page in an incognito window or another browser and immediately tried it again in Chrome, it would still not work. I would still get the same net::ERROR_TIMED_OUT errors for 30-60 seconds.

My home network consisted of:

Windows 7 Desktop & Ubuntu Media server plugged into a Trendnet TEW-432BRP Wireless router.   Both PCs used a wired connection (I did not use the wireless).  

I did not use the Trendnet router to do any routing.  I had the internet connection plugged into the Ubuntu machine that acted as my firewall/gateway.  It had a second network card that was plugged into the router, along with my Windows 7 PC.  The router only acted as a hub.  

I never used a browser on the Ubuntu machine, and so don't know if it was affected.  I only experienced the problems on Windows 7.

I replaced the Trendnet router it with an Asus RT-N66U, and reconfigured the network so the Ubuntu machine was no longer doing my routing.  Now the internet is plugged into the Asus router, which provides a connection to both PCs. 

Since I replaced the router, all the problems have gone away.

Hopefully this helps....



Comment 47 by Deleted ...@, Aug 28 2012

As a result, is there any workaround this issuue?

To wait for version 22 is the best way?
Labels: -Mstone-22
katsumi.akashi:  Unfortunately, there's no single cause for this error message, so there's no single workaround.  The error code means we opened a connection to a server, sent data (Either a request, or in the case of SSL, possibly just our half of an SSL handshake), and never heard anything back from the server.

The people reporting the issue are likely running into a number of problems.  One had a router that was causing it upstream, some are having issues only with SSL, one was having problems with a third party modification of Chromium.  It's not clear what the problem is in a lot of cases.

If you submit a network log (http://www.chromium.org/for-testers/providing-network-details), I'll be happy to take a look and see if I can figure out what the specific issue you're running into is.
Hi, I did that chrome://net-internals test as i get the issue only in certain sites. attached is the file, perhaps it contains some useful information :)
net-internals-log.json
962 KB View Download

Comment 50 by mmenke@google.com, Sep 7 2012

Aashish.Sharma.108:  Thanks for the log.  I took a look at it and can't spot anything obviously wrong, other than the fact the server never responded.  We sent out a request, size was reasonable, but the server never responded.

I'd guess it's one of the usual suspects (connection issue causing packet loss, server issue, or something deliberately dropping the request).  The last doesn't seem likely, in this case, since other requests to that server worked, and the request wasn't unusual in any way.  Since you're presumably running into this issue often enough to duplicate it on demand, I assume it's not a server issue, unless you're only running into errors with a single server.  So my guess would be a connection/networking issue, but these issues can be very difficult to figure out, so I have little confidence in that.

Sorry I can't be of more help.
I'm currently investigating an issue with older versions of natd dropping packets. Specifically for Freebsd but i'm sure other systems maybe affected. Anyone with information on their current router setup, if it's firmware based or software would be helpful. 
hi, Any clues as to the cause of this yet? I checked most of my network cables with a cable tester and had to replace a few. Now, the network errors are fewer but still occur. So, it can't be be a network issue for me (unless there are issues with hooking up a router to the main router).

I just have the main router being the virgin super hub (which is netgear) connected to another netgear router...
I still have this problem, but at work Chrome works. So its either a Virgin internet issue or something is wrong with my network and I have no clue as to where to start looking into my network for issues!

I have a virgin superhub acting as a router which is connected to another router upstairs for broader wireless coverage......
Aashish.Sharma.108:  Do you get the issue with other browsers?  If so, nothing much Chrome can do about it.
To be honest, I very rarely get blank pages/timed out in IE - but they do ocur but in Chrome they occur very regularly, so its probably either Virgin or my network. Trouble is I have no clue as to what to fix :(
Weird that IE doesn't give them - wonder if it's retrying aggressively on slow responses, or getting some sort of network signals that we're messing.  What version of IE are you using?
I use IE10 on my desktop and IE9 on laptop
Attached find log file with reproduced bug. 

Failed to load URLs opend in background tabs with error "Error 7 (net::ERR_TIMED_OUT): The operation timed out.".

If I open more pages in background tab, this is likely to happen. It never happens in Firefox or IE. Tested on older sigle core computer. It has not happend on my newer 4 core notebook yet (on the same network). Behind NAT router (ASUS RT-N12) on fast and stable fibre-connected internet.

I suspect it happens only on slow/single core computers [combined with fast connection?] - may be some synchronization issue?

Failed URLs:
http://www.zive.cz/default.aspx?pgnum=1
http://www.zive.cz/bleskovky/windows-blue-budou-optimalizovany-pro-tablety-s-mensi-uhloprickou/sc-4-a-166700/default.aspx
http://www.zive.cz/clanky/itunes-11-prehled-novinek-a-vylepseni/sc-3-a-166690/default.aspx
http://www.zive.cz/clanky/google-predstavil-g-komunity-a-bezplatny-snapseed/sc-3-a-166681/default.aspx
http://www.zive.cz/bleskovky/the-onion-apple-upravuje-realitu-tak-aby-odpovidala-jeho-mapam/sc-4-a-166676/default.aspx

Comment 59 by agl@chromium.org, Dec 10 2012

tarapcik: no files actually appear to have been attached.

Comment 60 by tarap...@gmail.com, Dec 22 2012

Sorry, I probably forgot to attach the file, here it is.
net-internals-log.zip
866 KB Download

Comment 61 by tarap...@gmail.com, Dec 22 2012

One more observation: today I had same problem, I opened site www.zive.sk and from it several articles in background tab. Chrome failed on most of them and then kept failing even on page reload. BUT: after I opened other  this site and chrome://net-internals/, reload started to work on previously failed zive.sk articles tab. 

It seams that either:
- problem is cured by opening another web site
OR
- problem is less likely to occure while chrome://net-internals/ logging is running

Comment 62 by tarap...@gmail.com, Dec 22 2012

Attached on more example: Failed to load http://mobilmania.azet.sk/clanky/rychly-test-lg-optimus-l9-kral-strednej-triedy/sc-3-a-1129589/default.aspx



mobilmania_failed.zip
849 KB Download
tarapcik:  In all those timeouts, we're reusing sockets that have been idle for 50+ seconds.

My best guess is that an upstream device (Possibly your personal router) silently closes old sockets after some very short timeout, and then when we send the second request on the old socket, the same device silently blackholes the request, rather than sending an RST (reset) message, like it should.  Since we never heard back, this results in a timeout.

Don't think there's much we can reasonably do about this.  We can retry afterall timeouts, but timeouts can take a while, resulting in pretty user experience for requests that repeatedly result in timeouts.  We can reduce the time we keep idle sockets around, but that makes things slower for the 99.9% of users without this problem.
There must be something wrong with Chrome though as all the other browsers don't have this issue.

Comment 65 by tarap...@gmail.com, Dec 29 2012

I'm not sure it's router bug:
- it happens to more users on different routers (OK, most are linux+busybox based, so the bug could be present accross different vendors) but:
- it happens only on my old one core PC, newer dual/quad core notebooks does not exhibit the bug
- no other browser has connection issues on the same PC
- no other network SW has connection issues on the same PC

To verify I did one more test to see if the bug is still present (yes it is - attached netlog). Consequently I used putty raw connection to test:
- I sent GET / HTTP/1.1, received response
- I waited >60 seconds, to simmulate reuse of socket idle 50+ seconds
- I sent another GET / HTTP/1.1, received response
- I waited indefinetely - after aproximately 3 minutes I got correct "Connection closed by remote host"
(log from putty attached).

So either chrome is ignoring connection close events or it opens sockets with some strange options that some "home" routers don't handle well.

Would it help to capture network packets using wireshark?

mobilmania_failed2.zip
325 KB Download
mmania_putty_29_132117.zip
22 bytes Download

Comment 66 by tarap...@gmail.com, Dec 29 2012

Wireshark logs:

mmania_packetschrome - apply filter "tcp.stream eq 10" - seems, after Keep-Alive packet the TCP stream really went "dead"

mmania_putty, mmania_firefox - seems putty and Firefox does not use SO_KEEPALIVE

mmania_packets_firefox_F.pcapng
294 KB Download
mmania_packets_putty_F.pcapng
2.1 KB Download
mmania_packets_chrome_F.pcapng
87.8 KB Download

Comment 67 Deleted

Comment 68 by tarap...@gmail.com, Dec 29 2012

Test on another computer (same router as above) - and it is getting TCP Keep-Alive responses (wireshark log attached).

Conclusion: on one of the computers I do not get keep-alive responses. I wasn't able to trace the reason (disabling windows firewall didn't help, there is no special config for that computer's IP address in the router, disabling router firewall did not help...)

PROPOSAL: remove SO_KEEPALIVE from socket options when connecting to web sites. It is not necessary for http connections and it could resolve problems with some consumer routers.
mmania_ok_pc_chrome_F.pcapng
99 KB Download

Comment 69 by tarap...@gmail.com, Dec 29 2012

The issue in my case was caused by "Check Point VPN-1 SecuRemote" (version NGX R60 HFA2 Build 052). I'll definitelly ask company IT guys for upgrade.

Anyway, I still suggest removing SO_KEEPALIVE as other users reported problem with routers and for short term http connections it is not needed (nor used by other browsers).
SO_KEEPALIVE was actually added due to  issue 27400 , which was home routers causing exactly this problem when it was not used.

Wonder if Android wakes up the radio for keepalive packets.
I think I fixed this bug :) at least for me. Basically I have an internet connected to a router connected to another router (coverage) and my computer is connected to the second router. I just got rid of the 2nd router and all is fine.

Comment 72 by Deleted ...@, Jan 9 2013

timeout problem still occur in chrome.
i notice it often happen with slow response site
is it possible to provide any flag to set min timeout manually ?
because some of important sites reply slow 
one of them is https://www.irctc.co.in which is an e-commerce site so its crucial not to timeout , other browsers wait till they get response regardless of time it take and they succeed.


We're just using the default Windows timeout values, which I believe is what other browser do as well.

We do enable TCP keepalive packets, though.  These are necessary to prevent some routers from blackholing connections after a minute or two of inactivity.  Doing this may cause issues with an even smaller number of devices.  If you're only encountering issues with Chrome, that may be the reason.

Comment 74 by Deleted ...@, Jan 11 2013

no it happens with most of the people using this site (mostly from 10 am IST to 2 pm IST), and same site load correctly in other browsers,slow but they do load page instead of time-out.
Firefox have setting in config network.http.connection-timeout for setting time-out.
can i change default window time-out value ?
That only corresponds to ERR_CONNECTION_TIMED_OUT, which is a timeout when establishing a connection, not ERR_TIMED_OUT, which is a timeout after a connection has been established.  It also only applies when it's less than the OS's default timeout - it does not increase the OS's default timeout.  Here's the comment from FireFox's code:

// The number of seconds after sending initial SYN for an HTTP connection
// to give up if the OS does not give up first
pref("network.http.connection-timeout", 90);

So it seems to me like something else is going on there.
Same issue here. Getting this error in various websites and when trying to access the servers from my work. I'm getting this error when I want to access the plesk panel, which have an "untrusted" certificate (coming so from the hosting company).

I attached the network log below and edited the subdomain name (it's a control panel and I don't want to post it due to security reasons). The domain in cause appears like:
xxxxx.vservers.es:8443


The panel is working just fine in Firefox, Opera and IE.
OS: Windows 8
net-internals-log.json
188 KB View Download

Comment 77 by alang...@gmail.com, Jan 30 2013

laszlo.j: it looks like some of the SSL connections to the Plesk instance are completing but, for some, Pleak simply never answers the ClientHello.

Is the problematic software running anywhere publicly accessible? 
@alang: That direction can be accessed from everywhere, if that's what I am asking. That is just an example, but happened on many websites which I first thought that were a server issue. Happened on random servers, so can't give some examples, because I can't remember. However, the number of them was isolated, most of time is happening only on pages with self-signed certificates (like control panels). I will try to find another example, but while the address I added the log for is not working in Chrome but works in other browsers, I guess is Chrome fault.
Project Member

Comment 79 by bugdroid1@chromium.org, Mar 10 2013

Labels: -Area-Internals -Internals-Network-HTTP -Internals-Network-SSL Cr-Internals-Network-SSL Cr-Internals-Network-HTTP Cr-Internals

Comment 80 by Deleted ...@, Dec 5 2013

I'm also having trouble with my connections timing out......Especially when I'm trying to download another page from a website....(i.e., pay a bill OR enter a contest)....It's really driving me nuts....HELP.
Screenshot.png
231 KB View Download

Comment 81 by Deleted ...@, Feb 18 2015

if any one has solved this error. please provide solution
Status: Archived
Going to go ahead and archive this issue - it's too much of a catchall, and posts made 2 years ago may well be irrelevant to any current causes of the error.

hussain21j:  Please file a new bug.  If you do so, please include an about:net-internals log of the issue occurring (Instructions here: https://sites.google.com/a/chromium.org/dev/for-testers/providing-network-details)
Components: Internals>Network
Components: -Internals>Network>HTTP

Sign in to add a comment