New issue
Advanced search Search tips
Note: Color blocks (like or ) mean that a user may not be available. Tooltip shows the reason.
Starred by 7 users

Issue metadata

Status: Fixed
Owner:
Last visit > 30 days ago
Closed: Apr 2012
Components:
EstimatedDays: ----
NextAction: ----
OS: Linux
Pri: 2
Type: Bug

Restricted
  • Only users with Commit permission may comment.



Sign in to add a comment

Playing an HTML5 video forces X to enable DPMS

Reported by kelytha...@gmail.com, Jan 24 2012

Issue description

Chrome Version       : 18.0.1010.0
OS Version: Arch Linux (rolling release)
URLs (if applicable) :
Other browsers tested:
  Add OK or FAIL after other browsers where you have tested this issue:
     Safari 5: N/A
  Firefox 4.x: N/A
     IE 7/8/9: N/A

What steps will reproduce the problem?
1. Disable DPMS, verify with xset -q
2. Open an HTML5 video on YouTube
3. Run xset -q again and see that DPMS is now enabled

What is the expected result?
Chrome should not forcefully enable DPMS.

What happens instead?
Playing an HTML5 video enables DPMS, a feature that is explicitly disabled in my xorg.conf!

UserAgentString: Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/535.18 (KHTML, like Gecko) Chrome/18.0.1010.0 Safari/535.18



 
Labels: Feature-Media-Video
Owner: imasaki@chromium.org
Cannot repro issue with 18.0.1010.0 dev on Ubuntu. after playing HTML5 YouTube, DPMS is still DISABLED.

Do I miss something here?
Maybe related to X version or drivers?

I use 1.11.3 and proprietary Nvidia drivers.
Here is result of chrome://gpu 

Canvas: Software only, hardware acceleration unavailable
HTML Rendering: Hardware accelerated
3D CSS: Hardware accelerated
WebGL: Hardware accelerated
WebGL multisampling: Hardware accelerated
Problems Detected
Accelerated 2d canvas is unstable in Linux at the moment.
Version Information
Data exported	Tue Jan 24 2012 16:04:20 GMT-0800 (PST)
Chrome version	18.0.1010.0 (Official Build 117846) dev
Operating system	Linux 2.6.38.8-gg705
Software rendering list version	1.25
ANGLE revision	941
2D graphics backend	Skia

X info:

X.Org X Server 1.7.6
Release Date: 2010-03-17
X Protocol Version 11, Revision 0



Hi, I have just tested the issue on a different computer. Again, latest development version of Chrome on 64bit Arch Linux, but this one is running the open-source Nvidia driver instead of the proprietary one.

The error happens just the same way. xset -q says DPMS is disabled, I play an HTML5 video on YouTube and run xset -q again, and DPMS is now enabled.

Is there anyway I can trace down what happens? Since I can consistently reproduce the issue on two different computers so far, it has to be there, and there has to be a way to trace it.

Labels: norepro
Owner: ----
Status: Untriaged
Getting dev's input.

Status: Invalid
This is working as intended
Mergedinto: 33605
Status: Duplicate
To clarify  issue 33605  implemented a power save blocker to keep the display from dimming while playing video.

I'll mark this as a duplicate for now but to clarify is your concern that your DPMS gets accidentally re-enabled even though it's always supposed to be disabled?

It could be that  issue 33605  doesn't recognize this case.
Yes, my problem is, that the DPMS gets enabled when it shouldn't, and especially that it is left enabled afterwards.

Both my home and my office computers show this issue.

Comment 10 by mdm@chromium.org, Feb 1 2012

Hmm. What's your desktop environment? Is this a recent change, or just something that you only recently noticed?
I use KDE with the VLC multimedia backend. I started to notice this problem at the end of December, but it took me weeks of testing till I traced it back to Chrome as it was the last thing I thought about.

Comment 12 by mdm@chromium.org, Feb 3 2012

If you run Chrome after unsetting the environment variables DESKTOP_SESSION and KDE_FULL_SESSION, does the same thing still happen? (This should tell us whether it's the power management integration or the video playback itself. Given other data it sounds like it's the power management integration.)
I've got the same problem with chromium 18.0.1025.45. It's not only that dpms is set to on, but it's set with timings 1 1 2 (that means after one sec is monitor dimmed). And I've noticed it's not only while playing html5 videos, but sometimes in any other site activities with a little bigger timings. However I can't say more now. There's something really wrong
Ok now I've noticed same behaviour when I start download something

Comment 15 Deleted

Comment 16 by jpin...@gmail.com, Apr 5 2012

I'm also seeing this on 18.0.1025.142 on FreeBSD and x.org. I disable DPMS in my .xinitrc so I was surprised to see the monitor shut itself off when I stepped away after leaving Chromium open.

Revising this since it seems to be relevant: It seems to only happen with the Tweetdeck extension active.

Unsetting KDE_FULL_SESSION seems to have stopped it for now.
Unsetting KDE_FULL_SESSION seems to work here too.

But the issue itself got worse with the last few updates. Now it is not only happening when watching videos, but other events seem to trigger it as well. And sometimes the screen blanking time gets set to as low as 1 second.

Comment 18 by mdm@chromium.org, Apr 24 2012

Labels: -Area-Undefined Area-UI
Mergedinto:
Owner: mdm@chromium.org
Status: Started
OK, I'm not sure why the behavior has changed, but I believe I've got a change ready that should disable the power save blocking feature when the user has explicitly disabled DPMS, which should take care of these cases. I imagine it should make it in M20.
Project Member

Comment 19 by bugdroid1@chromium.org, Apr 25 2012

The following revision refers to this bug:
    http://src.chromium.org/viewvc/chrome?view=rev&revision=133874

------------------------------------------------------------------------
r133874 | mdm@chromium.org | Wed Apr 25 01:09:18 PDT 2012

Changed paths:
 M http://src.chromium.org/viewvc/chrome/trunk/src/content/browser/power_save_blocker_linux.cc?r1=133874&r2=133873&pathrev=133874

Linux: don't use the DBus power save blocker if DPMS is disabled.
On some desktop environments, this can enable DPMS with poor defaults.

Also reformat a bunch of poorly-wrapped comments.

BUG= 111239 

Review URL: http://codereview.chromium.org/10218008
------------------------------------------------------------------------

Comment 20 by mdm@chromium.org, Apr 25 2012

Status: Fixed
This should be fixed in the next dev channel, and it'll percolate down to stable with M20.

Comment 21 Deleted

Project Member

Comment 22 by bugdroid1@chromium.org, Oct 13 2012

Labels: Restrict-AddIssueComment-Commit
This issue has been closed for some time. No one will pay attention to new comments.
If you are seeing this bug or have new data, please click New Issue to start a new bug.
Project Member

Comment 23 by bugdroid1@chromium.org, Mar 11 2013

Labels: -Area-UI -Feature-Media-Video Cr-Internals-Media-Video Cr-UI

Sign in to add a comment