Project: chromium Issues People Development process History Sign in
New issue
Advanced search Search tips
Issue 109918 Custom cursors loaded with url() randomly disappear
Starred by 10 users Reported by dyl...@gmail.com, Jan 11 2012 Back to list
Status: Duplicate
Merged: issue 111218
Owner: ----
Closed: Feb 2012
Cc:
Components:
NextAction: ----
OS: Mac
Pri: 2
Type: Bug

Restricted
  • Only users with Commit permission may comment.


Sign in to add a comment
Chrome Version       : 18.0.1003.1
OS Version: OS X 10.7.2
URLs (if applicable) : http://jsfiddle.net/athLR/5/
Other browsers tested:
  Add OK or FAIL after other browsers where you have tested this issue:
     Safari 5: OK
  Firefox 4.x: OK
     IE 7/8/9: OK

What steps will reproduce the problem?

Example: http://jsfiddle.net/athLR/5/

1. Set the cursor using url(image file) or url(data uri) on some element.
2. Mouse over that element.
2. Sometimes the cursor shows up fine.  Other times it does not show up. 
3. Switching tabs, interacting with other elements on the page, moving the mouse around, and changing the cursor can make it disappear or become visible.  There does not seem to be a pattern.

What is the expected result?

Custom cursor is used as long as the mouse is over the element that has the custom cursor style.

What happens instead?

Custom cursors disappears.  It doesn't even use the fallback built-in cursor.

Please provide any additional information below. Attach a screenshot if
possible.

UserAgentString: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_7_2) AppleWebKit/535.16 (KHTML, like Gecko) Chrome/18.0.1003.1 Safari/535.16


 
Comment 1 by dyl...@gmail.com, Jan 11 2012
I've been told Windows Chrome users see this issue as well, but they get the secondary cursor instead of no cursor.  I have not verified this with the example url provided.
Comment 2 by wac@google.com, Jan 18 2012
Also seeing this on same version Chrome on Mac OS X 10.6.8. Doing a reload on the page fixes the cursor.
Comment 3 by kush...@gmail.com, Jan 19 2012
Labels: -Area-Undefined Area-WebKit WebKit-SVG
Status: Untriaged
Reproduced on 16.0.912.75 and 18.0.1012.0 canary with OS X 10.6.8.
Comment 4 by a...@chromium.org, Feb 20 2012
Mergedinto: 111218
Status: Duplicate
Project Member Comment 5 by bugdroid1@chromium.org, Oct 13 2012
Labels: Restrict-AddIssueComment-Commit
Mergedinto: chromium:111218
This issue has been closed for some time. No one will pay attention to new comments.
If you are seeing this bug or have new data, please click New Issue to start a new bug.
Project Member Comment 6 by bugdroid1@chromium.org, Mar 11 2013
Labels: -Area-WebKit -WebKit-SVG Cr-Content-SVG Cr-Content
Project Member Comment 7 by bugdroid1@chromium.org, Apr 6 2013
Labels: -Cr-Content Cr-Blink
Project Member Comment 8 by bugdroid1@chromium.org, Apr 6 2013
Labels: -Cr-Content-SVG Cr-Blink-SVG
Sign in to add a comment