New issue
Advanced search Search tips
Note: Color blocks (like or ) mean that a user may not be available. Tooltip shows the reason.
Starred by 212 users

Comments by non-members will not trigger notification emails to users who starred this issue.

Issue metadata

Status: Fixed
Owner:
Email to this user bounced
Closed: Jan 2011
Cc:
Components:
EstimatedDays: ----
NextAction: ----
OS: All
Pri: 2
Type: Bug

Blocking:
issue 68200

Restricted
  • Only users with EditIssue permission may comment.



Sign in to add a comment

Chrome does not launch Java automatically for JNLP resources

Reported by craig...@gmail.com, Apr 23 2009

Issue description

Chrome Version       : 1.0.154.53
URLs (if applicable) :
Other browsers tested:
Add OK or FAIL after other browsers where you have tested this issue:
Safari 4:
  Firefox 3.x: OK
         IE 7: OK
         IE 8: OK

What steps will reproduce the problem?
1. Access any JNLP file
2. Chrome downloads JNLP file as if any other resource
3. Chrome does not start Java
4. User must click on JNLP file to start Java and associated app


What is the expected result?

Chrome should start Java automatically for the JNLP resource

What happens instead?

Chrome downloads the JNLP file to the file system

Please provide any additional information below. Attach a screenshot if
possible.


 
Showing comments 122 - 221 of 221 Older

Comment 122 Deleted

I just verified that it didn't auto launch my jnlp after clicking it in dev chrome 11.  This should ideally work just like an applet where the menu above pops up and asks if you want to run java application.  My concern is that it still is dumping the jnlp to Downloads and is numbering it file(1).jnlp, file(2).jnlp, etc. which will continue to take up space and never get cleaned up as it is not going to the temp directory and not getting cleaned up once the browser is closed.  I understand that customers can set auto-open of jnlp, but that is not what I'd like to happen.
java plugin image.jpg
155 KB View Download
google, i thought you didn't suck.
I haven't checked that with Google Chrome 11.
Maybe James Gosling can fix it for us now. 
Kenneth Bradley Russell and James Gosling are able to fix this bug but the problem does not rely in any Java source code as Chrome is written in C++. However, the fix already used in Chrome 10 works even though some people do not like its behavior and I provided another fix. If the code has not been deeply restructured, a new fix is not really necessary, otherwise I will give it a quick look.
This bug should not be marked as fixed.
BTW it is possible to achieve desired behavior by writing NPAPI plugin (there are download managers that integrate with Chrome this way).
Unfortunately sun/oracle never really cared. Even their Firefox integration is rather bad, yet Microsoft managed to integrate .NET ClickOnce properly.

Comment 130 by pfe...@gmail.com, Apr 4 2011

Below ASP code works fine within IE & Firefox
Chrome just save the target ASP file !!

Please fix it, no workarounds

Pedro

<%@  language="VBSCRIPT" codepage="1252" %>

<% 
Response.ContentType="application/x-java-jnlp-file"
Response.Write("<?xml version=""1.0"" encoding=""ISO-8859-1""?>")
Response.Write("<jnlp spec=""1.5+"" codebase=""http://www.SERVER.com/"" href=""file.jnlp"">")
...
Response.Write("</jnlp>")
%>
Hi guys,

you need to set JNLP files to auto-open. To do this:
1.) Download a JNLP file
2.) In the download bar, right-click the item
3.) Choose "Always open this type of file"

After that, this should work.
No, it doesn't work. If you do that then file is still downloaded to you Downloads directory.
@thakis I don't think it is expectable behavior for jnlp where the user has to select open or auto-open.  Most users do not even know what a jnlp file is or what to do with it.  For example, nobody expects to open a file when you launch an adobe air program.  Here is an example.  http://chessjam.com/ clicking install does not prompt you to save a file to open. It just launches the air installer.  I believe the same thing should happen for the jnlp.  All the other browsers perform in such a way.  If google is worried about launching something harmful then it should probably display something like what I suggested in comment 123.
@mwisnicki I don't agree with you, Firefox integration of the plugin 2 of J2SE 1.6 is excellent, there had been numerous problems with the plugin 1 but these problems did not affect Java Web Start as far as I know. .NET ClickOnce works only on a single family of operating system, you cannot compare this thing with Java Web Start. Can you tell me which version of Chrome you use please?

@thakis It works for me. However, I agree with the previous comment. The treatment of Java in Chrome is unfair, I see the (bonus) dangerous file warning whereas there is already the scary warning of Java Web Start for signed applications requiring some authorizations. If you want to discourage the final users from launching Java applications, keep the same behavior :(

@supag The default scary warnings of Java are enough, don't they? On which operating system did you try Chrome 11?

Comment 135 by pfe...@gmail.com, Apr 5 2011

Please, do you know why chrome is not handling "ContentType" (last tested version 10.0.648.204) ?
See comments #130, #102


@goues...
It's certainly less than excellent (unlike ClickOnce). Firefox basically treats JNLP exactly the same way as Chrome except it downloads this file to $TMP and I already mentioned that in comment 73. Such treatment causes JNLP files to not work if codebase is not hardcoded into them, yet codebase is optional according to jnlp documentation.

That ClickOnce works only on windows does not really matter as its Firefox plugin is pure javascript and very simple, it just catches download of clickonce file and passes the url to clickonce launcher. With 3 simple changes it could be used for JNLP.

Anyway this is mostly Oracle's problem. They can easily provide working WebStart solution for Chrome and Firefox if they want. Instead they (and Sun before them) choose to ignore bugs and other deficiencies of WebStart. In fact they don't even accept such bugs into their bug system (which is moderated).

I'm using Chrome 11 if you really need to know.
Oh and one more thing. There is a javascript jnlp deployment script which you are supposed to use at http://download.oracle.com/javase/tutorial/deployment/webstart/deploying.html, or more precisely http://www.java.com/js/deployJava.js.

Unfortunately it uses 'application/java-deployment-toolkit' mime type handled by special deployment plugin 'npdeployJava1.dll' that:
 1. is not registered with Chrome
 2. even though it's present in Firefox it does not seem to work there
And webstart deployment toolkit does not work by design ;)
From http://java.com/js/deployJava.txt:

   launchWebStartApplication: function(jnlp) {
       // This methos is disabled for the time being
        return false;
   },

Been that way since forever. Typical shit like you would expect from Sun.

Comment 139 by Deleted ...@, Apr 29 2011

I manually created a shell entry for .jnlp files in Windows and told it to open using the javaws.exe file. Once this was done, Chrome successfully opened the .jnlp file when downloaded.
Under XUbuntu Linux (with both Thunar and Nautilus properly opening the .jnlp files), this still does not work under Google Chrome version 13.0.761.0 dev.
I'm noticing that it's silently downloading the file to my Downloads folder, as mentioned in comment 132.

Comment 141 Deleted

original bug was files for chrome version 1 (!)
at version 13, two years later, still no solution or fix.

nice job :(

Comment 143 by Deleted ...@, Jun 22 2011

Another vote for Chrome not dealing with JNLP well.  Out of the box, I shouldn't have to download it and then manage settings in any way.  If anything, Chrome could have a pop-up confirming we want to run it, save it, or cancel.

Comment 144 by gro...@gmail.com, Jun 22 2011

I don't understand, how come it says status Fixed. It's not.
I use browser based application, for stock trading that requires Java Platform to run.
But Java doesn't start, so application doesn't work. I tried re-installing both
Java 6u26 and Chrome 12.0.742.100, no luck. It all works fine under IE9. 
Good job Google for not fixing it!

Comment 146 by Deleted ...@, Jun 26 2011

Still a problem on 12.0.742.100
Hello - I'm sorry that my earlier fix didn't fully fix the issue.

I'm starting to suspect that there might be a few different bugs in the same area.

Could someone who is still seeing a problem give a clear set of instructions to reproduce this? (Preferably involving an URL that can be visited to demonstrate the problem).
Make an account in http://www.fumbbl.com, create one team, buy the players and try to go PLAY with it.

Tutorials and stuff here: http://www.fumbbl.com/help:
@efreak2004: forgive me for not running a random piece of Java on the internet, but I had a quick look at the HTTP headers at least.
Does it not work if you select "always open files of this type" from the Chrome download shelf?
@scarybeasts. We appreciate your work on this. Could you clarify what version of chrome to use to test your changes? Also, with your changes, what is the expected flow now for jnlp files? 

I am running chrome 12.0.742.100. Here is what I am currently experiencing:

1. Click 'Clear auto-opening settings' in chrome://settings/advanced downloads section.
2. Click on a .jnlp link. The .jnlp file will be downloaded to the Chrome download shelf.
3. From the download shelf, select "always open files of this type"
4. From the download shelf, select "open".
5. Java webstart successfully launches. 
6. Click on link from step 2. again. Webstart successfully launches. 

I think what the community is requesting is the following 

1. Click 'Clear auto-opening settings' in chrome://settings/advanced downloads section.
2. Click on a .jnlp link. Webstart successfully launches. 




Comment 152 by gro...@gmail.com, Jun 27 2011

check comment: 
  8. http://code.google.com/p/chromium/issues/detail?id=10877#c8
131. http://code.google.com/p/chromium/issues/detail?id=10877#c131
132. http://code.google.com/p/chromium/issues/detail?id=10877#c132

regarding:
144. http://code.google.com/p/chromium/issues/detail?id=10877#c144
tomorrow I'll try to contact application developers for demo/test account,
since I'm kind of reluctant to give you mine ;)  
Also not interested in the cluttered download folder
See http://code.google.com/p/chromium/issues/detail?id=10877#c26

sorry, jircii is an irc client. more info @ jircii.dashnine.org

Comment 155 by Deleted ...@, Jul 8 2011

I did what the community has suggested, so when I click on the test links from java website- I get a nice splash screen from java showing me Java 6.. and then poof !!! there is no notepad file opened anywhere.

About Chrome gives Chrome version as 12.0.742.112 , I am running this on Vista.

@ conspiracy theorists - I dont think Google can stoop so low as to consciously disable/ prevent Java features from working just to get level with Oracle.. so 

Any Gurus/ Geeks who can help ?
It's extremely frustrating! The only thing, I can't use Chrome right now, is accessing IP Console for our servers. This URL can not be open with chrome:
https://managementhost/viewer.jnlp(managementhost@0@1310216803551)

Comment 157 by Deleted ...@, Jul 27 2011

@balogh.peter:  I'm having the same issue.  I want to manage Dell iDRACs on my servers.  The link is like you have posted.  Except, Windows thinks it's a different file extension every time you click the "LAUNCH" in the iDRAC.  What I mean to say is that the number at the end of the file changes, so Windows believes it's a different filetype each time.  Example file names:

viewer.jnlp(MYSERVERIP@0@idrac-DELL_SVC_TAG#,+PowerEdge+R410,+User-root@1311778252424)
viewer.jnlp(MYSERVERIP@0@idrac-DELL_SVC_TAG#,+PowerEdge+R410,+User-root@1311778291530)
viewer.jnlp(MYSERVERIP@0@idrac-DELL_SVC_TAG#,+PowerEdge+R410,+User-root@1311778852165)

These were all downloaded from the same server, during the same "session" on the DRAC.  Windows believes anything AFTER the dot (period) is the file extension.  Firefox/IE handle this just fine.  Please fix this.  Thanks!
It would be nice if you would support this, Every time I think I can move to chrome the inability to kick off JNLP programs makes me move back to firefox.

Comment 159 by ptu...@gmail.com, Aug 18 2011

I just ran into this bug with Google's App Inventor. Though I pass the tests for having Java installed, when I click on 'launch' on this link:

http://appinventor.googlelabs.com/ode/JWSTest/AppInvJWSTest.html

Chrome downloads the jnlp rather than running it.

14.0.835.94 beta
OS X 10.7.1

This issue is still occurring for me as well using Chromium 15.0.866.0 (Developer Build 98596 Windows)
Same problem here [13.0.782.215 (Build 97094 Linux)].
Switching to Firefox/Seamonkey until this gets fixed...
This was working great, until 15.0.874.5 dev-m broke it, click on downloaded.jnlp now nothing happens.
This problem is not fixed!
Java webstart should automatically run jnlp upon clicking on the link.
It should not be downloaded first and then run!
Google, please fix this or you will lose many chrome users.

Comment 164 by Deleted ...@, Sep 29 2011

not fixed yet.  I opted for the run this file type always method which seems to work for now

Comment 165 by Deleted ...@, Oct 14 2011

Having the same issues as "ptu...@gmail.com" with iDRAC. Windows see's every .jnlp file as a unique extension due to the embedded info on the file. Using IE for now to save time; would really love to see this resolved.
Still broken
14.0.835.202 m
jnlp file from Dell Drac works in Firefox, works in IE, just downloads in Chrome.
@aha..., @ptu...: Could you switch over to issue 92846?  That sounds like it may be something real.  @aha...: Can you say more about the windows behavior?  I'm not familiar with that, and that type of thing could easily get in the way of auto-opening jnlp files, since we delegate the opening to the OS.

i also have issues with the dell idrac. the automatically open these types of files trick doesn't work because the files rarely have the same extension. All other browsers seem to handle it ok including FF,IE9, and even Opera.

Comment 169 by pfe...@gmail.com, Oct 26 2011

15.0.874.102 m it's working fine, thank you!
Seems to be OS specific.

Doesn't work for me with 15.0.874.106 on Windows XP, however works on Windows 7.

JNLP's do not auto launch on Mac OSX Lion Chrome 15.0.874.106. Confirmed today.

I first noticed this behavior in the beta channel several weeks ago and switched to stable because of it.  Now it's in the stable channel.
I concur that this is an issue in 15.0.874.106 on Win7Pro 64bit and 32bit.

On our school campus, we use a java based gradebook. If you don't clear the downloads folder it would add a (X) where X is the next number of the same file name.  Now it downloads as "Program (X).jnlp" but it actually overwrites the file in the download folder called "Program.jnlp" and "Program (X).jnlp" never appears in the downloads folder.  If you click on the "Program (X).jnlp" in the download's list, it can't find it. (expected since it's not there)  

This overwriting the original file with the same name doesn't happen with other downloads of the same name (tested with PDFs)
Oh!! It has been solved on version 16 !!!

*
*
Oh! Finally in version 16.0.912.21 beta it has been solved!!

The mime-type is recognized and the browser open the jnlp file!

Comment 175 by Deleted ...@, Nov 24 2011

I'm using Chrome 16.0.912.41 beta on Linux and it doesn't open the jnlp file....

Comment 176 by Deleted ...@, Dec 8 2011

Doesn't open them here either...

Google Chrome	15.0.874.121 (Officiƫle build 109964) m
Besturingssysteem	Windows
WebKit	535.2 (@100034)
JavaScript	V8 3.5.10.24
Flash	11,1,102,55

Comment 178 by Deleted ...@, Jan 6 2012

This issue is not fixed.  Chrome simple saves the JNLP file in the download folder.
Issue is not fixed.

Comment 180 Deleted

Comment 181 by Deleted ...@, Jan 19 2012

Issue not fixed. Please fix it!

Comment 182 Deleted

Comment 183 by Deleted ...@, Jan 24 2012

K12 school system relies on .jnpl mime type. Pretty much if you don't fix this, kids being home schooled can't run under chrome.
Very not fixed, especially for Chromium OS. There is no workaround for this whatsoever, even with the console?
File is dumbly downloaded, on Ubuntu 11.04 : Chrome 16.0.912.77, with sun-java6-jre 1.6.0_26 properly installed, configured in Ubuntu alternatives for javaws, available everywhere else automatically in this OS.

Please re-open this bug as this behavior is really absurd and arbitrary (or not ? ^^)

Should Java applications developpers put a banner "Chrome browser is deprecated, please download Mozilla Firefox" on their websites, like some did in the past to encourage users upgrading their IE6 installations ?

Comment 186 by Deleted ...@, Feb 3 2012

This is not fixed. JNLP files are not launched correctly
Windows XP 16.0.912.77
Still not fixed. Attempting to use the Dell iDRAC just downloads the files. You can open them and tick the "always use Java Web Start" to open these files but as a previous comment shows the file name changes every time (session number?)
Please fix this, all other browsers I have work just fine.
Thanks

Comment 188 by Deleted ...@, Feb 8 2012

Still not fixed! How is this possible? This bug has been around since 2009!
I develop applications for biologists, and I use JWS for its simplicity. Chrome takes that away. 

Please fix!!
17.0.963.46: Still not fixed :-(

Comment 190 by Deleted ...@, Feb 17 2012

Not fixed. Still downloads jnlp regardless of system settings, MIME definitions, etc.

Comment 191 Deleted

Comment 192 by Deleted ...@, Feb 20 2012

its possible to auto start the jnlp but the file gets downloaded every time....

Comment 193 by Deleted ...@, Feb 29 2012

i'm here to add my voice to the crowd.  please fix!  where's my pitchfork, btw?

Comment 194 by Deleted ...@, Mar 1 2012

I found that JNLP auto launching stopped working after 100 launches.  

It looks like the jnlp file I use was being renamed with an incrementing number in order to save the file and avoid naming collisions e.g. my_program (15).jnlp then my_program(16).jnlp etc.  Once the incremented number hits 100 then the auto launch stopped working. 

To fix the problem I went to my downloads folder and deleted the accumulated files and now it's working again.  Seems like this should be simple to fix - allow infinite incrementing of the file numbers.

I'm on chrome 17.0.963.56m and Windows 7 Professional SP1
Oh my lord please fix this! My jnlp link even opens a new window, then I have to click show all downloads, then i have to click to keep the file, then FINALLY I can click to open the link, then I have to click to close the downloads tab and one more click to close the new window that was opened. 5 Clicks to launch the applet! Come on!

Comment 196 by Deleted ...@, Mar 23 2012

Finally got this working "Select a program from a list of installed programs" then go to your dir for \Java\jre6\bin\ and select javaws.exe don't forget to check allways open in the download menu.

Comment 197 by Deleted ...@, May 23 2012

Please fix this problem. Because of this I need to launch IE just to admin Cisco firewalls and Brocade FC Switches.
This becomes the major reason why I HAVE TO keep IE as my default browser :-(

Comment 199 by jechu...@uw.edu, May 31 2012

IE9 is pretty sweet anyway. I just have to code something up to sync my bookmarks from chrome and I'll be set.
Hi

Instead of complaining here, please help me to reproduce (and fix) this bug:
https://code.google.com/p/chromium/issues/detail?id=135363

The provided fix for the  issue 10877  works only the first time and you still have to click "Open" or "Always open this kind of file", that's why I created another bug report, because there is another bug. Best regards.
I want to just two things:

1. This bug is definitely not "Fixed" and should be re-opened or marked "Invalid, Bug is in Sun/Oracle Java distribution not providing correct NPAPI hooks to handle the MIME-type 'application/x-java-jnlp-file' correctly".

2. If this bug is re-opened, it should be about adding a workaround for the mess caused by Sun/Oracle. Basically the Chrome/Chromium should default to "Open this file type automatically" in case the MIME-type 'application/x-java-jnlp-file' can be handled by the OS.

This issue is marked as fixed but it is still not working for me. I have to confirm to keep the file then open it after it's downloaded to launch the Java app. Agree with others, VERY ANNOYING, BAD USER EXPERIENCE.
Blocking: chromium:68200

Comment 204 Deleted

Sept 10, 2012 -- Chrome v21.0.1180.89 on Win7x64 Platform
PROBLEM:  DELL DRAC JNLP files do not automatically open.
ISSUE:  Dell DRAC creates a JNLP file with DYNAMIC extension. Example Format: viewer.jnlp(drac.mgmt.xyz.com@0@idrac-XXXXXXX,+PowerEdge+T710,+User-sg@1345674212307)
Note that in the above example, the extension of the above file is: .jnlp(drac.mgmt.xyz.com@0@idrac-XXXXXXX,+PowerEdge+T710,+User-sg@1345674212307).  The last part of the above extension (e.g.: @1345674212307)changes every time,  you click on the link.  Chrome doesn't know how to handle a a dynamic extension such as the one mentioned.  Most other browsers (e.g.: FF, IE, etc.) can handle the dynamic extension.

It's WORRYSOME to see that this problem was reported back in 2009 and we are in 2012.  Are there any fixes, workarounds?
This past weekend, I helped someone with a website that uses JNLP. It was a bit of a hassle, but it's certainly do-able. Bits of these instructions are in the 200 comments above, and I agree it's a bad experience. However, I suspect it's the Java plugin's fault for not associating .jnlp files with Java Web Start (javaws.exe).

Instructions for Windows are roughly like this. It may vary depending on what version of Windows you are running:

1) Install the latest version of Java. As of this writing, it's Java 7 Update 7. Reboot if it prompts you to, etc etc.
2) Start Chrome, go to your website and click on the link on the website that uses JNLP.
3) It will download the JNLP file and ask you to keep / discard it. Keep the download.
4) In Chrome, click the drop down arrow next to the finished download, select "always open files of this type"
5) In Chrome, click the drop down arrow next to the finished download, select "open folder"
6) In Windows Explorer, find the downloaded .jnlp file, right click it, and select "open with".
7) In the open with dialog, click browse, select c:\program files (x86)\Java\...\bin\javaws.exe, and select ok.
8) Back to the open with dialog, select Java Web Start as the program to open with, and make sure the "always open with ..." checkbox is checked. Click open.
9) Go back to Chrome, and try the link on the website that uses JNLP again, it should download the JNLP file, launch Java, and delete the JNLP file.
As I had mentioned in my previous post:  The extension part of the filename is dynamic and therefore what is suggested by thestig@chromimum.org will NOT work.  Here's an example:  
Session 1:  Dynamic Filename:  file1.jnlp(user1)
Session 2:  Dynamic Filename:  file2.jnlp(user2)
NOTE: Extension for the two files above are different:  
   .jnlp(user1) 
   .jnlp(user2)

The file extension has to be the same in Windows to configure "always open file type".

Comment 208 Deleted

such a major "bug" (or lack of a standard feature) that is not resolved for over 3 years. Is this a joke?
I almost fell in love with you Chrome. Back to Firefox (it actually knows how to handle .jnlp files).

Comment 210 by Deleted ...@, Jan 23 2013

I think the issue was fixed in the last iDRAC7 firmware, 1.23.something, but it's back again for iDRAC7 freshly updated to 1.30.30 build 43.
Under Linux Chromium, my issue comes down to being able to evaluate the following javascript in the JS console:

> navigator.mimeTypes["application/x-java-jnlp-file"]

On Firefox, this returns the correct result (a mime type). On Chromium/chrome it doesn't.

If there's nothing to be done on the Chromium side for this, this bug should go to invalid, shouldn't it?
I think my issue is independent, filed as https://code.google.com/p/chromium/issues/detail?id=177199
Project Member

Comment 213 by bugdroid1@chromium.org, Mar 10 2013

Labels: -Area-Internals -Feature-Downloads Cr-Internals Cr-UI-Browser-Downloads

Comment 214 by Deleted ...@, Jun 24 2013

+1 for fixing dynamic jnlp extension bug, very annoying...

Comment 215 by Deleted ...@, Jul 1 2013

also, the .ed extension, please

Comment 216 by Deleted ...@, Jul 22 2013


this is not "Fixed". Chrome keeps downloading the file instead of opening. It can be opened with javaws but that does not work as Samsung is checking cookie info as their credit-usage system.
Version 28.0.1500.71
Linux fedorabook 3.8.13-100.fc17.x86_64 #1 SMP Mon May 13 13:36:17 UTC 2013 x86_64 x86_64 x86_64 GNU/Linux

Running Java webstart stuff is a basic capability - one Chrome does not have.

Comment 217 by rexs...@gmail.com, Jul 22 2013

OH wow, a late congratulations to the 4th anniversary of this thread... As stated by #207, the extension of the jnlp files of A LOT OF IPMI console on server platforms like Dell iDRAC is Dynamic.

e.g. filename = "viewer.jnlp(10.15.09.127@0@1374518867258)"

And the extension name will include the session id and some more information and every time you click the launch button, the extension will be different, so it is the responsibility of the browser to parse the filename or file header and pass the file to java virtual machine to run. 

IE 8 9 10 can handle the launch without error, just Chrome will download the stupid file...

Comment 218 Deleted

This is absolutely horrible. Please fix this bug concerning dynamic jnlps! 

Currently we can't advise our customers to use chrome/chromium because of your 4-year defiant attitude regarding this issue...

Comment 220 by Deleted ...@, Oct 21 2013

It is almost end of 2013 ... Is there way to bump priority for the issue?
Labels: Restrict-AddIssueComment-EditIssue
This bug is marked as Fixed. If there are still problems (and it sounds like there are), the most productive course of action is to file a brand new bug with an uptodate, explicit test case.

This bug is sufficiently muddled that it's not clear what the requested behavior change is.
Showing comments 122 - 221 of 221 Older

Sign in to add a comment