New issue
Advanced search Search tips
Note: Color blocks (like or ) mean that a user may not be available. Tooltip shows the reason.

Issue 108645 link

Starred by 136 users

Comments by non-members will not trigger notification emails to users who starred this issue.

Issue metadata

Status: Verified
Owner:
Closed: Apr 2012
Cc:
Components:
EstimatedDays: ----
NextAction: ----
OS: Mac
Pri: 1
Type: Bug-Regression

Restricted
  • Only users with EditIssue permission may comment.



Sign in to add a comment

"font-family": Local font shows odd symbols/characters

Reported by rmnet....@gmail.com, Dec 26 2011

Issue description

Chrome Version       : 18.0.983.0
OS Version: OS X 10.6.8
URLs (if applicable) : http://lifevaluesinventory.org
Other browsers tested:
  Add OK or FAIL after other browsers where you have tested this issue:
     Chrome (16.0.912.63): OK
     Safari 5: OK
  Firefox 4.x: OK
     IE 7/8/9: OK

What steps will reproduce the problem?
1. Install a web font locally. I'm using "Museo Sans" with is free from FontSquirrel.com (I imagine you can do the same with a font from Google Web Fonts).
2. Create an HTML page and add a "font-family" property that references the *local* name of that font *first* and then the online version *second*.
   ex: font-family: "Museo Sans", "MuseoSans500", sans-serif;
3. Load the page in Canary (18.0.983.0).

What is the expected result?
- The local version of the font will be used (so a font download from the server isn't necessary) and look like readable text, not wacky characters.

What happens instead?
- The local version of the font is garbled and shows weird characters (see attached screenshot).
- Canary must not realize the text is garbled, because it doesn't fall back to the online version.
- When I remove the reference to the local version, Canary uses the online version and looks fine.
    ex: font-family: "MuseoSans500", sans-serif;

Additional Notes
- I think there's a been a slight regression of: <http://code.google.com/p/chromium/issues/detail?id=72727>
- Originally, that bug (72727) wasn't using the local version of the font at all and wasn't falling back to the next font in line (in this case, the online version). Instead, it would display the text as Times New Roman.
- Eventually that was fixed and Canary was working fine. I just tested this again the other day against a site and testcase that I'd used to test 72727 against and I saw these weird characters. So I think some new bug has been introduced into the same system that was going funny in 72727. Only this time, instead of Times New Roman, it's something a bit worse :-)
- You can download MuseoSans500 from <http://www.fontsquirrel.com/fonts/Museo-Sans>. I didn't attach it here because I wasn't sure about licensing.

- I've attached screenshots (Testcase: normal size + enlarged, example site) and my testcase (the first and second line of text should use the same font).
 
Screen shot 2011-12-26 at 12-26, 12.04.09PM.png
37.2 KB View Download
Screen shot 2011-12-26 at 12-26, 12.04.23PM.png
53.4 KB View Download
Chrome-font-face-bug-testcase.html
1.2 KB View Download
Showing comments 74 - 173 of 173 Older
Project Member

Comment 74 by bugdroid1@chromium.org, Apr 11 2012

Labels: merge-merged-1084
The following revision refers to this bug:
    http://src.chromium.org/viewvc/chrome?view=rev&revision=131699

------------------------------------------------------------------------
r131699 | bashi@chromium.org | Tue Apr 10 19:31:02 PDT 2012

Changed paths:
 M http://src.chromium.org/viewvc/chrome/branches/1084/src/content/renderer/renderer_webkitplatformsupport_impl.cc?r1=131699&r2=131698&pathrev=131699
 M http://src.chromium.org/viewvc/chrome/branches/1084/src/content/common/mac/font_loader.mm?r1=131699&r2=131698&pathrev=131699
 M http://src.chromium.org/viewvc/chrome/branches/1084/src/content/browser/renderer_host/render_message_filter.cc?r1=131699&r2=131698&pathrev=131699
 M http://src.chromium.org/viewvc/chrome/branches/1084/src/content/browser/renderer_host/render_message_filter.h?r1=131699&r2=131698&pathrev=131699
 M http://src.chromium.org/viewvc/chrome/branches/1084/src/content/common/mac/font_loader.h?r1=131699&r2=131698&pathrev=131699
 M http://src.chromium.org/viewvc/chrome/branches/1084/src/content/common/sandbox_mac_fontloading_unittest.mm?r1=131699&r2=131698&pathrev=131699

Merge 131324 - Mac: OOP font loading should run on FILE thread.

FontLoader calls file_util::GetFileSize() and file_util::ReadFile(),
which should be called from the file thread, but FontLoader runs on the
io thread now. Make it run on the file thread.

BUG= 108645 
TEST=none


Review URL: http://codereview.chromium.org/9950141

TBR=bashi@chromium.org
Review URL: https://chromiumcodereview.appspot.com/10052006
------------------------------------------------------------------------

Comment 75 by Deleted ...@, Apr 11 2012

actually worst update I've experienced. Hate to switch to other browsers just to read some text.
when is this going to be fixed and pushed as update?
I'm using foxfire for my banking now [hopefully a temporary situation]. See attached Chrome screenshot.
Banking Screenshot 2012-04-11 at 10.03.47 AM.png
55.3 KB View Download
Sorry, Firefox
I'm getting it too.
Running Chrome 18.0.1025.151 on my Mac Pro with Font Agent Pro. I have to switch to Safari now. Firefox is interminably slow, and this bug has made Chrome completely unusable. I can't read anything on any site, my gmail content, etc.  Please notify me if it's ever fixed.  Or is there is any way to revert to a previous version of Chrome that didn't have this problem?

Thanks!
Screen Shot 2012-04-11 at 2.10.20 PM.png
395 KB View Download
You can use an extension called Change Font Family Style to force Chrome to use a certain font family. It's no fix for coders but it's a quick fix for regular users. https://chrome.google.com/webstore/detail/aabledekpjmoghdjnpnhfkfpmjifklpb

Comment 81 by Deleted ...@, Apr 11 2012

This just started happening to me today! I don't understand why it just all of the sudden is an issue. I'm using Chrome 18.0.1025.151, Mac OS X 10.7.3 and FontExplorer 3.1.1.

I found a tutorial on some methods to fix this via YouTube, but it only appears to apply to Safari. Not sure if I had this issue in Safari beforehand...but I don't have it there currently, only in Chrome.

Like many of the previous posters, I'm in web design/development...I cannot remove FontExplorer, and I don't want to move my whole process into an alternative browser...this is a joke!

I'm new to this whole forum thing on here...what's the current status with this? I'm confused about that.


Update: My igoogle homepage seems to be finally displaying correctly [at least for the moment], but many other pages are not -- including my own website that is built with google web fonts [www.efsmart.com] -- and other miscellaneous sites [my bank, etc.]. 

Per comment 81, when this is finally resolved, please release non-technical instructions.
Comment 81: Did you install a Creative Suite 5.5 upgrade prior to your browser problem? I'm trying to decide if this is the cause of the problem or just a coincidence.
Using OS X 10.6.8 with Suitcase Fusion 3 v14.2.0 (319) and experiencing same, but still using CS5 here.  Hadn't made any changes to my system at all (with the probable exception of updating Chromium) when this issue started out of the blue a couple weeks ago.

I neglected to include the font mgmt software in my initial bug report on 3/30/12 located here:
http://code.google.com/p/chromium/issues/detail?id=121108 - comment 3, because it didn't seem relevant when all other browsers tested worked normally.

Comment 85 by Deleted ...@, Apr 12 2012

I have CS 5.5, but have ad it for a while and never had this problem.

Comment 86 by Deleted ...@, Apr 12 2012

Mstone-19, does that mean we have to wait for 19?
This bug has been around since weeks.. yet, nothing happens...
Are you forcing us to switch to firefox or safari? seriously?

Comment 87 by edupr...@gmail.com, Apr 12 2012

Yeah. Is quite annoying to work under such conditions in the browser. For those looking for a temporary "fix" / workaround, deactivating locally installed fonts in FontExplorer and I suppose any other font management software helps. At least does for me. 

The bug seems to be related to locally activated fonts only. 

Comment 88 by dhw@chromium.org, Apr 12 2012

 Issue 123146  has been merged into this issue.

Comment 89 by bashi@chromium.org, Apr 12 2012

Status: Fixed
I'd like to close the bug as Fixed, given the fix landed trunk and M19 branch. I'm not in a position to decide whether we should merge the patch to the current stable channel.

Comment 90 by Deleted ...@, Apr 12 2012

I don't understand how this could possibly be marked as "fixed".  I'm sure there's some technical reason you're marking it as such because you found a fix, but it's not fixed.  I'm in Chrome right now, on StackOverflow, and all the code is still showing up as glyphs.  I'm not interested in trunks and branches, I'm interested in the Chrome that I have installed, which is set to auto-update itself.  Please do not marked this as FIXED until it is actually fixed AND PUSHED to the masses.
That's how software development works.  The bug is fixed.  Getting it built and pushed in another issue.  Marking the bug as fixed is correct.
Maybe I missed something in the thread, but it seems like a workaround has been found. The bug is not fixed. Right? It's like saying my car is fixed because I can jump-start it; it's still not operating properly.

Does it just  mean the solution has been found but not yet implemented?
I was reading and sent here for this issue from google groups. the suggestion was to download museo sans. I went there and it is a page that when clicked for download takes you to a sales page; where the font is 134.00. I think that is a bit of a scam. Here's the link... Don't get tricked into buying. http://www.fontspring.com/fonts/exljbris/museo-sans
"Maybe I missed something in the thread, but it seems like a workaround has been found. The bug is not fixed. Right? It's like saying my car is fixed because I can jump-start it; it's still not operating properly."

This.  One million times this.

I understand what you're saying about "this is how software development works", but I disagree.  Until the fix is in the hands of the users, it is not really fixed.  It is identified, and under active development, but it is not truly fixed until there is a release.  When a client sends a bug over and I fix it locally, I don't tell them it's fixed until we release said fix to them.  That's how software development works to me.
My igoogle page has returned to normal. Here's a page from an online news org...still exhibiting the font problem. My own web page [efsmart.com] is still a mess.
Screen shot 2012-04-12 at 11.06.31 AM.png
360 KB View Download

Comment 96 by kareng@google.com, Apr 12 2012

bashi, we need to wait until it goes out with m19 first. We need to make sure there are no future merges needed and this is indeed fixing the issue.
I'm a little confused. @chromium guys - are you trying to be jerks and just saying "Fixed! Closed! Good luck! See yah!"   
Is code.google.com more like a bugzilla or JIRA and we just happen to be able to sit here and annoy the crap out of you while you guys resolve? 
Come on guys - give us a little more to work with. I don't understand what "given the fix landed trunk and M19 branch." means. If you don't want the public to make your lives hell, then why gives access to your bug management system?
WHY ARE YOU CLOSING THIS BUG? WHAT DO US NORMAL PEOPLE DO NOW? 
don't be developer dicks and have some people skills for 5 mins.

Comment 98 by Deleted ...@, Apr 12 2012

Maybe we need more information like WHEN is m19 coming?
Does that mean we have to wait like 1 week? 1month? or even unclear?
Not sure how long it took when 17 became 18.
But to me it looks like we just arrived at 18. So I guess we have to use firefox/safari for like several months now? ;)
Or live with some ugly workarounds?
Guys... wake up ;)

Comment 99 by reed@google.com, Apr 12 2012

My read is:

1. we have a fix
2. we are testing it against M19
3. if the fix looks good, we will attempt to back-patch it into M18

And to clarify to those wondering, M18 is the current stable release, and M19 is the current unstable beta. M20 is the dev version, aka Canary.
Thanks guys! 
Hopefully those new to the issue will read your comments before posting more redundant screen shots and issues.

In the meantime, I'll get comfy with safari and FF and keep an eye on this thread. 
You'll have to accept apologies from those of us who post redundant screen shots and issues. We don't mean to be bothersome. We don't understand fully how you handle these sort of things, and often find your notes difficult to follow. We speak from the viewpoint of being ordinary non-tech people who assumed that developers want to see what we are seeing, and that somehow we would fresh our browsers each morning and all this would be worked out.
Any real solution to this F++n problem??!!
come on..


Comment 104 by kareng@google.com, Apr 12 2012

hey bashi, can you please land this on 1025 as well so I can have a build ready? 

thanks!

Comment 105 by Deleted ...@, Apr 12 2012

I'd suggest some developer puts this as a patch to some version that is about to release as next.
m19 is simply not the right target for such an issue.. this is not a feature, this is a serious BUG.
Are older releases of chrome available for download? I'd like a better workaround than 'switch to another browser'. I'll direct my customers to it if they contact us about this issue.

Also, can Google's support or marketing team put out a public statement about this bug? I run the support department for a font management developer. We've gotten some heat over this issue, so it would be nice to have something official to direct our customer base to.


 Issue 123226  has been merged into this issue.

Comment 108 by Deleted ...@, Apr 13 2012

what's the timing on this fix?

i've been swithing back and forth to other browsers and would like to know if we're talking a day or a month?
C'mon google devs! Can someone please just say: "we hope to have this issue fixed in X days/weeks"? I'll just stop using Chrome altogether if this is the way you treat major bugs...

Sincerely,
John
Seeing this issue on OS X 10.6.8, Chrome 18.0.1025.162. I'm not using any font management software. 


Chrome_Font_Problem.gif
26.4 KB View Download

Comment 111 by Deleted ...@, Apr 15 2012

google actually pushed an update few days ago I believe. But no changes about this issue.
Still switching between two browsers.

Comment 112 by kareng@google.com, Apr 15 2012

Are any of you using the Beta channel? We believe this issue was fixed on the Beta channel on Friday with version 19.0.1084.24. We'd love to have some feedback so we can make sure we push the fix to the Stable channel too.

Comment 113 by Deleted ...@, Apr 15 2012

where to get it?
@comment113, beta channel is available here:
http://www.google.com/landing/chrome/beta/
Re: Comment 112 by kar...

I commented way back on April 6, 2012 (Comment 56) that the fix landed and works in Canary <http://tools.google.com/dlpage/chromesxs>.

I also asked a few questions along with that report. None of which were really addressed. Even as everyone else started asking the same ones.

a.

Comment 116 by Deleted ...@, Apr 15 2012

ok, got the beta installed and seems to be working fine.
Beta working for me as well.  Thanks for the fix!
Screen shot 2012-04-15 at 10.47.09 AM.png
178 KB View Download

Comment 118 by Deleted ...@, Apr 15 2012

Fix seems to be working for me. Thanks.
Status: Verified
Verified as fixed with chrome 18.0.1025.163 (Official Build 132135).
No, it wasn't fixed in version 18. I was running that one up until this morning and it never worked for me with any regularity. I had switched to Safari because I do have to read the text on web pages. ;) I use Font Agent Pro on a Mac Pro. 

However, I've switched to the beta version of Chrome (Version 19.0.1084.24 beta) and it appears to be fixed there. Thank you!

Comment 121 by kareng@google.com, Apr 16 2012

.163 is not released yet. The note is from our QA team testing it :) 

Thank you for confirming the fix in the Beta channel. 
Oops! I'm sorry, I think I spoke too soon. I do still have a problem with google calendar for some reason. See screenshot (the dropdown menu to choose my calendar). I cleared my cache and refreshed before taking in this in case that makes any difference... Looks like other sites that were all in gibberish (including my gmail) are working though...


Screen Shot 2012-04-16 at 11.46.42 AM.png
144 KB View Download
Seems the font loading code for form elements (in this case select widgets) is in a different code path, which was not patched, yet.

It would still be nice to have this fix released in stable channel first (as it fixes the majority of the websites and the majority of the impact of the bug) and continue the form elements font garbling issue afterwards or in another issue?
Verified that the issue is resolved in 18.0.1025.163 & 19.0.1084.24
OS tested: Mac 10.7.2
It looks fine for me with the 18.0.1025.163 (Official Build 132135) on  Mac 10.7.3 with calendar app also.

Comment 126 by Deleted ...@, Apr 16 2012

calendar looking good to me using the beta channel chrome
 Issue 123601  has been merged into this issue.
ffranz: Please file a separate bug with as much detail as possible.
jeremy: I am not having the problem, but was referring to Comment 122.
shushude...: As per comment 128: Please file a separate bug with as much detail as possible.

Comment 130 by kareng@google.com, Apr 16 2012

just pushed stable channel for mac: http://googlechromereleases.blogspot.com/2012/04/stable-channel-update_16.html hopefully 18.0.1025.163 should fix this problem. thank you for your patience.
I'm running Version 19.0.1084.24 beta; still patches of convoluted fonts, although not as bad as before. Am I using the wrong version?
OSX 10.7.3 and Chrome 19.0.1084.24, issue resolved. It works as expected now.
OSX 10.6.8 and Chrome Chrome 19.0.1084.24, issue not resolved. I know you hate the screen captures, but here is a new example
Screen shot 2012-04-18 at 1.26.53 PM.png
229 KB View Download

Comment 134 by Deleted ...@, Apr 18 2012

OSX 10.7.3, CS5 and FontExplorer...updated to Chrome 18.0.1025.163. Staus: Working. Thanks!
18.0.1025.163 is also working for me. Thank you!
If anyone is still having issues then please file a new bug and post the bug number here. Otherwise, if it's working for you, no need to post here.

Thanks!

Comment 137 Deleted

Again, please file a *new* bug with as much detail as possible and post the bug number here - a detailed bug report will help us find the root cause of the issue.

Comment 139 Deleted

Comment 140 by Deleted ...@, Apr 24 2012

Still having this issue. It's not a closed bug.
Just a minute ago. Version 19.0.1084.30 beta
It's not a closed bug
Screen shot 2012-04-24 at 2.04.32 PM.png
207 KB View Download
Also still having this problem as of 4/24 at 2pm EST. This bug is far from closed/fixed.
Was updating from 17.X to 18.X.X when I discovered this thread due to a large number of glyph occurrences.

Downloaded 19.X.X and still had same issue.

Downloaded 20.0.1130.1 dev and SOME of the glyph occurrences were fixed (approx 4/5 no longer happen), but there's still a few glyph occurrences lingering as you can see by the attachment
Screen Shot 2012-05-10 at 10.25.43 PM.png
91.2 KB View Download
I'm going to firefox until this is resolved. Some websites are totally useless because of this...

Comment 145 by epoger@google.com, May 16 2012

As Jeremy wrote above: If you are still seeing a problem, please file a *new* bug with as much detail as possible and post the bug number here - a detailed bug report will help us find the root cause of the issue.

It seems like there are multiple problems with similar symptoms; separate bugs will help us sort that out.

Comment 146 by Deleted ...@, May 16 2012

Separate bugs also makes it nearly impossible for anyone with an interest in this bug to track changes and fixes.  How about we just put our detailed reports in this, the main bug entry, so everyone who has starred this can see it and follow your progress.  It's bad enough I can't do my work properly, now you want me to search all over for open bugs related to this exact same issue?  Ridiculous.  My steps to reproduce the problem are exactly the same as the ones listed above.  Why in the world should I enter that as a separate bug?  It's the same bug.  It happens on any version of OSX that I've tried it on, and every version of Chrome that has come out since this ticket was created.  Sounds like the same bug to me.

Comment 147 by epoger@google.com, May 16 2012

Hello couponuser80,

I know you appreciate a good deal, so I'm glad you enjoy Chrome's cost-performance ratio (up until now anyway).

I am sorry about your frustration.  Believe me, there are a number of us who actually want to help.

Tell you what: let's make a deal.

You...
1. Go to https://bugs.webkit.org/enter_bug.cgi?product=WebKit and file a new bug.
2. Keep that bug as narrow as possible.  Pick the single version of OSX you use most often, and the most recent version of Chrome you might like to use.
3. Fill that bug with details: exact Chrome version, exact OS version, anything "interesting" about the way you maintain fonts on your system, and exact reproduction instructions (what site you are visiting, etc.)
4. Update this bug with a link to that one.

And I will try to make sure that your bug is addressed.

Comment 148 by epoger@google.com, May 17 2012

Whoops, in my comment just above, step #1 should have read:
1. Go to https://code.google.com/p/chromium/issues/entry?template=Defect%20on%20Mac%20OS and file a new bug.

That's what I get for all the context-switching.
Done with Chrome, this has been going on way too long, and progressively getting worse:

Screen shot 2012-05-25 at 10.41.09 AM.png
329 KB View Download
That's wikipedia, by the way...

Comment 151 Deleted

FWIW I had this issue on all occurrences of helvetica on a page - wikipedia looked like the example above. This was just now using Version 20.0.1132.17 beta. 

I fixed it by unloading all but the system versions of helvetica (I use Linotype FontExplorer) and restarting Chrome.

I've since reloaded some of the versions of helvetica (I do graphics work so have several families of helvetica) and haven't encountered the issue again.

Comment 153 by Deleted ...@, Jul 12 2012

I had this same problem and turned off any version of Helvetica I had in Suitcase, restarted Chrome and it works fine.

Comment 154 by spo...@gmail.com, Jul 27 2012

I'm having this same issue (Chrome and FontExplorer). I can't be constantly disabling base fonts like Ariel and Helvetica all the time, and I can't be cutting and pasting text out of my browser just to read the page.

So it looks like I'll be going back to Firefox until Google fixes this ridiculous, and annoying, issue.
deactivating Helvetica seems to solve the problem. Have substituted
Helvetica Neue, and it works fine as a replacement. I didn't deactivate
Arial.

Still an annoying problem for such a basic need


 *
*Simplifying and clarifying communications for your marketing and sales.

*Stephen Hall* |* *Marketing design and new concepts for print,
advertising, presentations and the Internet.
☎ Tel: 321-449-0400 | Mobile: 321-536-5379
www.efsmart.com
 Contact me: [image: Skype] efsmart-creative
The latest at efsmart.com Clickable Paper by Ricoh: the wave of the future
or just a passing thought on the way to a useful Google
Goggles?<http://efsmart.com/clickable-paper-by-ricoh-the-wave-of-the-future-or-just-a-passing-thought/>

Comment 156 by k...@google.com, Aug 8 2012

Labels: -Merge-Approved
Removing Merge-Approved from past milestones.
Having the same problem as everyone else here. What I'm finding really odd is that the fonts show up fine if you open the problem page in Incognito mode. There seems to be no rhyme or reason why this is happening. If there's a font issue, shouldn't it happen whenever the page is open?
I'm getting something similar after upgrading to Chrome 21.0.1180.82. I'm on OS X Mt Lion 10.8. I tried 1) incognito mode and 2) a new chrome profile and still got the same problem.
jgraph_diagramly-confluence.png
129 KB View Download
Google Web Fonts.png
141 KB View Download
Your font issue seems to be different. Most of the other posts here are getting some glyphs (see my attachment), not blank boxes. Wonder why Chrome won't play nice with fonts. 
Screen shot 2012-08-23 at 7.12.36 PM.png
962 KB View Download
Our Google Apps customer is not seeing this as resolved at this point.

Comment 161 by Deleted ...@, Sep 12 2012

My problems now solved.

• Chrome: Version 21.0.1180.89
• OS: 10.7.4
• Suitcase Fusion 3 Version 14.2.1 (332)
    (and, with 'Google Web Fonts' enabled - under the 'File' drop down menu.)


When I updated my Opera to version 12.02 - I noticed similar font rendering issues....!!!!  (i almost cried)
To me, the problem just got worse, as it was also in Opera, not just Chrome anymore.

Attached images are an example between opera and chrome before I fixed the problem on my machine.

>> In Suitcase, I disabled from my own font sets,  the font "Arial MT",  - the  'Adobe Systems' Foundry font... !!!!
- I did not disable the 'Arial MT', - the 'Monotype Library' Foundry font.
Still in suitcase, I did not deactivate the 'Arial Rounded MT Bold' font inside System Font/Local folder.

So I only deactivated one font. The Adobe Systems Arial MT font.

Everything now displays perfectly in Chrome AND Opera for me.
Seems I may now be able to begin to use Chrome, as well as the latest Opera.!

It is a great pity that Chrome and now Opera are releasing a tool that is not solid.
Firfox and Safari are perfect. they always have been.

FYI.
Safari Version 6.0 (7536.25) - always perfect
Firefox 7.01 - always perfect
Firefox 12.0 - perfect
Chrome Version 21.0.1180.89 - was bad until Arial MT deactivated. (Adobe Systems Arial MT) - now perfect
Opera 12.02 build 1578 - was bad using this version, until Arial MT deactivated. (Adobe Systems Arial MT) - now perfect

Seems there have been lots of cache, font management, browser, etc blaming, hacks and fixes, - but I cannot connect any dots between users with this problem, from both mac and pc...  Are we all using Adobe applications? Is it in fact Adobe causing this nightmare? This one nasty Adobe Arial MT Font?

Gee, I hope my fix helps others.
chrome 21.0.1180.89.png
60.5 KB View Download
opera 12.02.png
88.2 KB View Download

Comment 162 Deleted

Comment 163 by Deleted ...@, Sep 14 2012

This really sucks. I had this problem on OSX Lion and installed a fresh OSX Mnt Lion thinking it would go away. WRONG. It definitely seems to be a conflict with Font Explorer. Running the latest version of Chrome.

Anyway Removing Arial MT or any of that isn't working. 

My temporary work around which has worked but won't be convenient for everyone is this Extention: 
Change Font Family Style
https://chrome.google.com/webstore/detail/aabledekpjmoghdjnpnhfkfpmjifklpb

- Kudos to "monna.ko...@gmail.com" for the tip. Comment #80

It works at least but I suppose it will change all fonts to whatever you set (helvetica font family for me). I'm sure that can be a problem on some sites and for some developers on here. 
Same issue for me. I love chrome, but I've probably waisted 10 hours of or my week trying to fix this issue, so moving to firefox until it is fixed. Using Version 22.0.1229.79 with FontExplorer X Pro. For me the garbled font is "sans-serif"
Screen Shot 2012-09-25 at 2.52.40 PM.png
651 KB View Download

Comment 166 by Deleted ...@, Sep 26 2012

Same issue,
working with lion and fontexplorer X.
See here, chrome in the left and firefox  in the right... >> http://puu.sh/18VfL

It's really strange because when i zoom in or out (cmd + "+") a part of the font is displaying good... or when i'm opening an other window of the same site i can see different result ???!! >> http://puu.sh/18Vn1

Can't understand that at all :-(


 Issue 121108  has been merged into this issue.
Labels: Restrict-AddIssueComment-Commit
Both this bug and the bug merged into it were marked closed in early April. It sounds like there's a new bug that needs to be filed; I've left the team, but hopefully caryclark@ or bungeman@ can look into those if they're in rendering, or bashi@ or one of his colleagues if they're in WebKit fonts. Meanwhile closing comments on these two bugs because their known root causes have been addressed.
Project Member

Comment 169 by bugdroid1@chromium.org, Mar 9 2013

Labels: -Area-WebKit -Type-Regression -WebKit-Fonts -Mstone-19 Cr-Content Type-Bug-Regression Cr-Content-Fonts M-19
Project Member

Comment 170 by bugdroid1@chromium.org, Mar 14 2013

Labels: -Restrict-AddIssueComment-Commit Restrict-AddIssueComment-EditIssue
Project Member

Comment 171 by bugdroid1@chromium.org, Apr 6 2013

Labels: -Cr-Content Cr-Blink
Project Member

Comment 172 by bugdroid1@chromium.org, Apr 6 2013

Labels: -Cr-Content-Fonts Cr-Blink-Fonts
 Issue 120929  has been merged into this issue.
Showing comments 74 - 173 of 173 Older

Sign in to add a comment