New issue
Advanced search Search tips

Issue 100138 link

Starred by 23 users

Issue metadata

Status: Untriaged
Owner: ----
Cc:
Components:
EstimatedDays: ----
NextAction: ----
OS: Windows
Pri: 2
Type: Bug



Sign in to add a comment

URI schema links to external applications navigate away from the current page

Reported by corrie.e...@gmail.com, Oct 13 2011

Issue description

Chrome Version       : 16.0.907.0
OS Version: 6.1 (Windows 7, Windows Server 2008 R2)
URLs (if applicable) : http://mgnet.me/.eclipsephase
Other browsers tested:
Add OK or FAIL after other browsers where you have tested this issue:
Safari 5:
Firefox 4.x:
IE 7/8/9:

What steps will reproduce the problem?
1. Open the example URL
2. Click on the magnet:// link
3. The external application (uTorrent in my case) is launched. 

What is the expected result?
The web page on which the link appears must remain the active page. Only the external application should be launched, nothing else should happen.

What happens instead?
Chromium navigates to a page with the same URI as the magnet link, and then displays an error page for "Error 302 (net::ERR_UNKNOWN_URL_SCHEME): Unknown error."

This is not correct behaviour, and is also new. This worked in all versions up to and including build 104258. I skipped some versions, and it stopped working before or in build 105024. 

Please provide any additional information below. Attach a screenshot if
possible.

UserAgentString: Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/535.7 (KHTML, like Gecko) Chrome/16.0.907.0 Safari/535.7



 
chromium 16.0.906.0 (Developer Build 105130 Windows) XP

I'm seeing this same behavior for mailto:// links. Clicking a mailto:// link will open by default mail client correctly, but it'll also take me to an error page with mailto:email@domain.com in the omnibar and this in the body:

This webpage is not available
The webpage at mailto:email@domain.com might be temporarily down or it may have moved permanently to a new web address.
Error 302 (net::ERR_UNKNOWN_URL_SCHEME): Unknown error.
This appears to be fixed as of 16.0.909.0 (Developer Build 105595 Windows)
I can confirm this has been fixed. 

Comment 4 by mega...@gmail.com, Nov 18 2011

I am seeing this bug in 17.0.942.0, when purchasing products from Steam (you can click a link to launch a steam: protocol link that triggers Steam to immediately install your new purchases).

Comment 5 by Deleted ...@, Nov 20 2011

The issue has returned in 17.0.942.0 dev
Yes, I am also seeing this error in 17.0.942.0 dev.  The specific error is:
 Error 302 (net::ERR_UNKNOWN_URL_SCHEME): Unknown error

It occurs whenever I use the Google "Email This Page" extension that is located at https://chrome.google.com/webstore/detail/dbeoemfhkdniadbojeencpkgmobndpai 

Comment 7 by Deleted ...@, Nov 23 2011

i have the same problem in the version of chromium: 17.0.945.0  with mailto
whenever i click on a email adress i get a 302 error. I installed the extension mailto and it works perfectly but i wanted to do it without the etension but its not possible. 

Comment 8 by sbara...@gmail.com, Nov 24 2011

Same problem with steam:// and itms:// (iTunes) links.

Comment 9 by Deleted ...@, Nov 24 2011

I think this is a generic problem with all launcher links in 17.0.942.0 dev.  Just got the same problem trying to launch a Mumble server as well, works perfectly in IE / Firefox. 
I can confirm that the issue is also present in 17.0.949.0 (Developer Build 111502 Windows).

I think this is bug has a big usability impact, and it should be looked at soonest.
This defiantly happens across all launcher links in 17.0.942.0 dev. It is fixed in 17.0.954.0 canary though.
Cc: pbomm...@chromium.org
Labels: -Area-Undefined Area-Internals
Status: Untriaged
CC-ing to the Installer tester - Pruthvi .. Encountered the same issue , uTorrent  getting automatically launched .. 
Magnet links in Chrome (17.0.963.0 dev-m) on Windows 8 (Developer preview build 8102) do not work.  Clicking the magnet link has no apparent effect.  Magnet links do work in all other browsers (Firefox, Opera, Opera Next, IE) on the same machine.

Comment 14 by 4bra...@gmail.com, Dec 7 2011

Working correctly again in 17.0.963.0 dev Mac

Comment 15 by Deleted ...@, Jan 20 2012

Magnet links in Chrome (16.0.912.75 m) on Windows 8 do not work.
Magnet links are also not working in Chrome (18.0.1010.1 dev-m) on Windows 8.  Clicking the magnet link has no apparent effect.  Magnet links work in all other browsers tested (Firefox, Opera, IE) on the same machine.
In Chrome "Options > Under the Hood > Content Settings > Manage Handlers" there is no way to add a protocol.
To clarify, it isn't just magnet links that do not work.  Any 'special' URLs do not seem to work.  This includes mailto links, as well as any application specific links (Steam links (should open the Steam client, Magnet links (should open bittorrent software), itunes links (should open itunes application)).
Give this a try as a work-around. It's not mine. I haven't verified it.

http://magnet-uri.sourceforge.net/magnet-uri-example-js.html

Thanks for the link.  (http://magnet-uri.sourceforge.net/magnet-uri-example-js.html)

I tried all four magnet links on this site (in Chrome, current dev), and all four gave me an error message stating that I have no magnet compatible programs running.  This is false, as Āµtorrent was running before, during, and after my test.
Running the test from the same linked website in Firefox 9 and I received the same error.

Using example (1) at this site:
http://magnet-uri.sourceforge.net/magnet-draft-overview.txt

-in Firefox:  I select the link, copy, then past in the URL bar, then hit enter.
-->result:  Āµtorrent opens and gives an error (expected behavior)

-in Chrome:  I select the link, copy, then past in the URL bar, then hit enter.
-->result:  Google search for pasted text

It seems as though Chrome is not recognizing these special links as any sort of link.  I see no way to add the protocol as a handler in the options either.


Still no change as of 18.0.1025.7 dev-m.  Again, magnet links (and other special link types requiring a handler) are unresponsive in windows 8 (developer preview)  All other browsers work on the same machine running Windows 8.
Magnet links (and other links requiring handlers) work as expected in Chrome 18.0.1025.7 dev-m on another machine I have running Windows 7 x64.

Should I post this somewhere else?

Comment 21 by aho...@gmail.com, Mar 4 2012

This seems to continue to be an issue with Windows 8 Consumer Preview (they work fine in Internet Explorer). Using 19.0.1055.1 dev-m.
Same here.  Special protocol (lastfm:, itms:, magnet:, etc.) works in Windows 8 Consumer Preview using IE, Firefox, Opera, and Opera Next (all current versions as of 3/5/2011).  The very same links do nothing when clicked in Chrome 19.0.1055.1.

Comment 23 by Deleted ...@, Apr 21 2012

Same issue, Windows 8 consumer preview... all updates applied.  Running Chrome "18.0.1025.162 m" and Magnet will not open.

It is not listed in my Protocol_Handler in the Local Slate file.  I noticed things like mailto, news, snews are configured as False.  I am wondering if I can just add Magnet to the protocol handler list and set it as true and see if that will solve the issue.

Comment 24 by Deleted ...@, May 24 2012

I am experiencing the same issue, Windows 8 Consumer Preview... Works fine in FF and IE, but no go in Chrome... This is a bit annoying since Github release their new Windows app, so github-windows:// links just fail.

Comment 25 by mega...@gmail.com, May 24 2012

I'm on Windows 8 Consumer Preview, I'm not experiencing this problem anymore.  21.0.1145.0 dev-m

So, it's possibly fixed and it just hasn't been merged into stable (yet).
Confirmed FIXED on Win 7 Canary 21.0.1150.
Project Member

Comment 27 by bugdroid1@chromium.org, Mar 10 2013

Labels: -Area-Internals Cr-Internals
Labels: Cr-UI-Browser-Navigation
Probably navigation related.

Current status: When external protocol link is clicked, the URL seems to stay unchanged. But when you switch to another tab and switch back to this tab, the URL is changed to the external protocol link.
Chrome version 35.0.1851.0 (Official Build 252439) canary mac.
also affects version 33.0.1750.117 (Official Build 252094) mac.

magnet links open appropriate external app (transmission)
they also open a new tab with the exact same URL, however, it does not appear to be loading the page, nor does it produce any error messages.

attached is example of open tab
magnet tab.tiff
83.1 KB Download
Cc: mea...@chromium.org
ScriptMan07: Are you opening the link in a new tab, for example by middle clicking on it? Or maybe the page that contains the link is trying to open it in a new tab.

When opened in a new tab, the app that handles the protocol will launch, and but the new tab will stay empty. That seems to be working as intended.

Sign in to add a comment