New issue
Advanced search Search tips
Note: Color blocks (like or ) mean that a user may not be available. Tooltip shows the reason.

Issue 928 link

Starred by 154 users

Comments by non-members will not trigger notification emails to users who starred this issue.

Issue metadata

Status: Fixed
Owner: ----
Closed: Nov 2014
Cc:



Sign in to add a comment

ChromeDriver 2.11 not working with Chrome 38 in Windows Server 2008R2

Reported by victor.p...@datahug.com, Oct 9 2014

Issue description

See http://goo.gl/ll2FvQ for common issues.

Issue Description:
ChromeDriver can not communicate with Chrome in Windows Server 2008R2

Environment Details
- Windows Server 2008 R2 SP1 (x64)
- Chrome (38.0.2125.101 m)

Steps to reproduce:
1. Execute simple Selenium test against Chrome (example below)

Example test:
IWebDriver _driver = new ChromeDriver();
_driver.Manage().Window.Maximize();


Error details:

Stacktrace

MESSAGE:
Initialization method WebAppTests.HomePageTests.Initialize threw exception. OpenQA.Selenium.WebDriverException: OpenQA.Selenium.WebDriverException: The HTTP request to the remote WebDriver server for URL http://localhost:3581/session/446827e125ab6df59b48ebfde1a33a9a/window/current/maximize timed out after 60 seconds. ---> System.Net.WebException: The operation has timed out.
+++++++++++++++++++
STACK TRACE:
    at System.Net.HttpWebRequest.GetResponse()
   at OpenQA.Selenium.Remote.HttpCommandExecutor.CreateResponse(WebRequest request)
 --- End of inner exception stack trace ---
    at OpenQA.Selenium.Remote.HttpCommandExecutor.CreateResponse(WebRequest request)
   at OpenQA.Selenium.Remote.HttpCommandExecutor.Execute(Command commandToExecute)
   at OpenQA.Selenium.Remote.DriverServiceCommandExecutor.Execute(Command commandToExecute)
   at OpenQA.Selenium.Remote.RemoteWebDriver.Execute(String driverCommandToExecute, Dictionary`2 parameters)
   at OpenQA.Selenium.Remote.RemoteWindow.Maximize()
   at Datahug.AutomationFramework.GUI.CommonUtilities.Browser.Initialize() in c:\buildworkspaces\WebApp-FunctionalTests-Build\Datahug.AutomationFramework.GUI\CommonUtilities\Browser.cs:line 59

Other details:

- All other actions timeout as well (is not an isolated issue with .Maximize())
- It works correctly in Windows 7 SP1
- Issue seen after upgrading Chrome to v38 in the Windows Server machine

 
Showing comments 46 - 145 of 145 Older

Comment 46 by m.no...@gmail.com, Oct 22 2014

We are experiencing the same issue. Solved temporary with chrome downgrade.

Comment 47 by conan...@gmail.com, Oct 22 2014

We're experiencing this too. Launching as service via TeamCity does not work with Google Chrome v38.
Seeing the same issue running Protractor tests via Bamboo with the following configurations:

* Windows 2008 R2 / Windows 2012 R2
* chromedriver 2.10 & 2.11

Unfortunately I can't find a working link to a Chrome 37 installer, the all re-direct to latest.  Going to try to get this working with Chrome Canary for now.
Does any one have installer for chrome 37 that We could use.
I found that the link in #33 above worked http://code.google.com/p/chromedriver/issues/detail?id=928#c33

The link in #35 just redirects back to the latest chrome install.
http://code.google.com/p/chromedriver/issues/detail?id=928#c35
I have this issue too. After rolling back to chrome 37,the console shows null
When rolling back to Chrome 37 I was unable to install Chrome for all users. For Jenkins I had to set the user account associated with the service to the same user I installed Chrome 37 with. Only then did it start working. I believe the cause is that the Chrome installer for v37 does NOT install it for ALL users. Basically, Google is actively avoiding supporting the installation of old versions of Chrome, which unfortunately leaves a lot of people in a broken state.
In directory "C:\Program Files (x86)\Google\Chrome\Application" You have file named "old_chrome.exe", You could change name from "chrome.exe" to "chrome_temp.exe" and rename "old_chrome.exe" to "chrome.exe". In gpedit.msc You need to download template for google chrome update and disable automatic updates. This method prevent feature problems. I recommend testing the new version on the development machine.

Comment 54 by ast...@zoosk.com, Oct 23 2014

My resolution: 

I didn't want to be stuck on chrome 37 without the possibility of knowing if google will eventually fix the problem with interacting with the jenkins service.

1) autologon to my VM's
2) put a batch file in the startup directory for all users which is essentially the "java -jar slave.jar..."
3) make the slaves go into a lock screen after a minute.

This way, it allows for the VM's (Jenkin slaves) to be auto logged in and start their jenkin slave. If you need instructions on how to do this: write a script to enable remote registry editing, then writing another script to allow you to auto logon with the credentials you want, then write a third script to place a batch file of your choosing into the start up folder.
We are also facing the same issue on
Chromedriver : 2.10 & 2.11 
chrome version : 38
Windows server
Jenkins  

I tried by reverting back to Chrome version 37 but getting following exception "org.openqa.selenium.WebDriverException: unknown error: cannot find Chrome binary"

But chromedriver binary was placed in the path and it is defined through system.setproperty().

When i installed chrome version 37, i couldn't able to see chrome binary fine in the following path "C:\Program Files"

please suggest me to overcome this issue.

 #55 k.sivaku...@gmail.com 

Use chromedriver ver. 2.10 instead of 2.11. 
The v37 installer of Chromedriver is installing it for the current user only, probably under Users\<username>\AppData\Local\Chrome\Application, or similar.

Comment 58 by oljat...@gmail.com, Oct 24 2014

Same here.

Comment 59 by ast...@zoosk.com, Oct 24 2014

#56 - What does chrome driver v2.10 get you?  

When my set up was Jenkins as a service, I tried chrome driver 2.9, 2.10, and 2.11 and none of them worked with chrome v38.


As a workaround on Jenkins, we have had some success running the Jenkins slave from a command prompt rather than as a service(early days, we'll see how it fares over the weekend).

Steps:
1: Open Windows services on the slave.
2: Stop, and disable, the Jenkins agent service.
3: Navigate to the agent's page in Jenkins
4: Run the command it offers you to run on the agent, something like: 
javaws http://<your-jankes-xenkins-hostname>/computer/<jenkins slave name>/slave-agent.jnlp

Since the problem only appears to manifest when people run selenium via something running as a service(or similar), running the jenkins agent as a user process seems to workaround the issue. I've no idea if there are similar things people can do for their TeamCity setups, but good luck!
After rolling back to v37, I was able to get past the Chrome binary not found issue (Jenkins) by overriding the location of chrome via a Selenium option:

String path = "C:\\Users\\Administrator\\AppData\\Local\\Google\\Chrome\\Application\\chrome.exe";
ChromeOptions options = new ChromeOptions();
options.setBinary(path);
WebDriver driver = new ChromeDriver(options); 
Project Member

Comment 62 by baran...@gmail.com, Oct 25 2014

 Issue 935  has been merged into this issue.
After rolling back to v37, i can able to execute my tests, solved temporary.
This matches what I'm seeing. In our case there's a maven project testing a web application; running from a Windows 7 machine at the command line works, but the same job fired using Jenkins on a Windows 8.1 slave fails with timeouts - weeks ago it was working fine. In both cases our chromedriver.exe is dated May 2014.

I suggest the title of this issue is changed as right now it appears to be limited to Windows 2008 rather when run as a Windows service.
Well, you might want to temporarily swap to Firefox until this is fixed...
:download for chrome 37: http://www.filepuma.com/download/google_chrome_37.0.2062.124-6932/download/ . also using the latest version of chrome ie 38 and chrome driver 2.9 somehow worked. didnt try latest chrome browser with chromedriver 2.10 though.
I also have the same problem running latest version of Chrome with TeamCity. Could NOT solve it by downgrading to ChromeDriver 2.9.0.1, didn't try 2.9.0.0 though. I'm switching to another browser until problem has been solved.
I tried ChromeDriver 2.9 too with Chrome v38. It seemed to work in interactive mode - however I didn't run our full suite of regression tests. Running under a service account failed.

I also tried downgrading to Chrome 37 using the link in #33. Unfortunately this seems to be the installer for the current user only. For service accounts, we need to install for all users.

The link in #66 seems to be Chrome 37 for All Users.

Comment 69 Deleted

did you try to use ChromeDriver v2.12 with Chrome Browser 38?
Denys, 
do you suppose that it can fix the issue? 
I don't see any information in the release notes that can be related to this:  http://chromedriver.storage.googleapis.com/2.12/notes.txt
I've just tried it and 2.12 is still not working.
(Session info: chrome=38.0.2125.111)
(Driver info: chromedriver=2.12.301325 (962dea43ddd90e7e4224a03fa3c36a421281abb7),platform=Windows NT 6.3 x86_64) (100)
Steps to downgrade Chrome to earlier version on Win 7/Win Server :
>> Go to "Program Files (x86)\Google\Chrome\Application" and rename "old_chrome.exe" to "chrome.exe".
>> Go to "%LOCALAPPDATA%\Google\Chrome\User Data\" and rename the folder "Default" to some other name. 
>> Launch the Chrome and disable Auto Update ( hit "chrome://plugins/" in browser and disable auto update)
We are facing same issue with Jenkins and selenium. As a workaround, we have rolled back to Chrome 37 and continued with our tests. What is the plan regarding a fix for this issue?
Eagerly waiting for the solution. As a workaround stopped jenkins slave service and manually Launch agent from browser on slave.
I've tried downgrading to Chrome 37 using the link in #66 (http://www.filepuma.com/download/google_chrome_37.0.2062.124-6932/download/) but when chrome starts it is still 38.  What am I missing?  I disabled Google update in plugins.  I don't see one called Chrome update.
Thanks.

Comment 77 Deleted

I updated ChromeDriver to the latest (2.12) and it's still not working for me either. I don't know if this is congruent with the issues you all are seeing, but when I run my RSpec script (written in Ruby), the instance of Chrome launches, it just doesn't do anything afterwards; my window resize command doesn't happen and the navigate.to() doesn't fire.

I'm using Windows 7 Enterprise and my Chrome is version 38.0.2125.111 m. Very frustrating as we have automation we're working on as well, and this is basically a huge blocker.
Hi all, we had a similar issue and we solved it yesterday, the problem was with the anti-virus, the anti-virus wasn't allowing the chromedriver to connect, we talk with our IT department and we asked them to add an exception rule on chromedriver, now the driver is allowed connections and our tests run with no problem.

Hope this helps, becauseI know you may be frustrated with all the "downgrade Chrome/Chromedriver" solutions
In our case we have AVG and Microsoft Security Essentials - we've made no changes to either but I've not checked if your suggestion works for us yet either. Maybe a job for tomorrow.
We don't have any antivirus on our servers and the problem remains.
See https://code.google.com/p/chromium/issues/detail?id=422218 which was referenced in link #32. It appears they will be fixing this in Chrome rather than ChromeDriver.
Its working fine in Chrome37 & chromedriver 2.9.


But Chrome is automatically updated to version 38.0.2125.111 m. Even I set the Google update in Disabled mode. using chrome://plugins/.

Option2: I tried to set the Google update -disabled using "regedit" . But i didnt find the Update folder itself.
Same problem as #83.

Automatic update is disabled, yet it seems overnight we now have Chrome version 38 on another one of our automation controllers. I double checked the automatic update settings - it is still disabled!

Does anyone know how to truly prevent Chrome from updating? Ideally we need a solution where even if someone requested a manual update of Chrome, it would fail.

Option 2 also does not work for us - the registry entries described don't exist.
Looks like this issue is related with that Chrome bug:

https://code.google.com/p/chromium/issues/detail?id=422218

Hope the Chromium guys get to fix it for the next Chrome release. Please star that issue so we make it more urgent.
Hello,

Today I got latest version of Chrome exe V 2.12 and Standalone server 2.44, and we started facing same issue. Everything works when we run Standalone Hub and Node manually but when we run them using task scheduler then nothing works.

Please update if someone found solution related to this issue.
#84 to stop Chrome from updating you need to get the "Google Update Administrative Template" and add it to your group policies in Windows. There you can disable the update function reliably.
Facing same issue,

Not able to run my test case in chrome 38, using robotframework, Selenium2Library
 (Session info: chrome=38.0.2125.111)
 (Driver info: chromedriver=2.12.301325 (962dea43ddd90e7e4224a03fa3c36a421281ab
7),platform=Windows NT 6.1 SP1 x86_64),
Hello guys,
I have configure a windows slave that runs bdd-security using chromedriver 2.9 and chrome Locally (in slave windows) everything is running fine. However, when I run the job on master Jenkins, the chromerdriver is up but hanging. Does any one have any idea?


Thanks               
Yes, I have this idea that few people trouble to read the thread and realize that everybody is having the same problem, thus making the thread so noisy I have to sign off it and not know when an actual solution has materialized. Oh well.  
Mergedinto: chromium:422218
Status: Duplicate
This is a regression in Chrome, so I'm merging this bug into the bug in the Chromium issue tracker. Updates will appear in that bug.
@samu - can you provide a link to the chromium issue so that we can follow it?
That's the related chrome issue:

https://code.google.com/p/chromium/issues/detail?id=422218

Comment 94 by mingz...@gmail.com, Nov 10 2014

Hope this will be fixed.
Same problem here. 
Jenkins, 
Windows 7 Professional x64
Chrome 38.0.2125.111 m (64-bit)
ChromeDriver (v2.9.248315)

Comment 96 Deleted

New version of chrome was released - 38.0.2125.122. Has any body checked, is problem already fixed?
Thread #97, Its not working in new release 38.0.2125.122
You'll need to wait for Chrome 39 which should be released in a week, or you can try the beta in the meantime.
So is it expected to be fixed on Chrome 39?
This was fixed and released on 11/18 in Chrome 39.0.2171.65. I updated and tested with chromedriver 2.42 under a Windows service and it worked.

Comment 102 by maju...@gmail.com, Nov 19 2014

Hi everybody,

I had the same issue but it seems to be solved after I updated chrome to version: 39.0.2171.65 which was released yesterday. I am using chromedriver version: 2.12.

Hope this problem will be fix for all of you folks.

Regards, Karol
Hi Everybody,

How to upgrade Chrome version on Jenkins.

Please update me asap

Thanks

Comment 104 by maju...@gmail.com, Nov 19 2014

You don't update chrome on Jenkins but on your (virtual) machine. Plus if you want to update chromedriver simply put the newer version to your project repository. This is how I do it.
Is there anyone else who is still facing same issue even after upgrading to latest chrome?
My settings:
chrome: 37.0.2062.124/103 and 39.0.2171.65 
Driver: 2.9,10,12
Win 7 64bit
Selenium version 2.42
Got this in log:
org.openqa.selenium.WebDriverException: unknown error: cannot determine loading statusfrom timeout: Timed out receiving message from renderer: 600.000 (Session info: chrome=39.0.2171.65) (Driver info: chromedriver=2.12.301325 (962dea43ddd90e7e4224a03fa3c36a421281abb7),platform=Windows NT 6.1 SP1 x86_64) (WARNING: The server did not provide any stacktrace information)Command duration or timeout: 600.05 secondsBuild info: version: '2.42.2', revision: '6a6995d31c7c56c340d6f45a76976d43506cd6cc', time: '2014-06-03 10:52:47'System info: host: 'NCEVC-00252', ip: '10.64.158.246', os.name: 'Windows 7', os.arch: 'x86', os.version: '6.1', java.version: '1.6.0_26'Session ID: 4dfd6d34926aeb9b5218366ab7a12bcdDriver info: org.openqa.selenium.chrome.ChromeDriverCapabilities [{platform=XP, acceptSslCerts=true, javascriptEnabled=true, browserName=chrome, chrome={userDataDir=C:\Users\$NCEOC~1\AppData\Local\Temp\scoped_dir5788_20334}, rotatable=false, locationContextEnabled=true, mobileEmulationEnabled=false, version=39.0.2171.65, takesHeapSnapshot=true, cssSelectorsEnabled=true, databaseEnabled=false, handlesAlerts=true, browserConnectionEnabled=false, nativeEvents=true, webStorageEnabled=true, applicationCacheEnabled=false, takesScreenshot=true}]	at sun.reflect.NativeConstructorAccessorImpl.newInstance0(Native Method)	at sun.reflect.NativeConstructorAccessorImpl.newInstance(NativeConstructorAccessorImpl.java:39)	at sun.reflect.DelegatingConstructorAccessorImpl.newInstance(DelegatingConstructorAccessorImpl.java:27)	at java.lang.reflect.Constructor.newInstance(Constructor.java:513)	at org.openqa.selenium.remote.ErrorHandler.createThrowable(ErrorHandler.java:204)	at org.openqa.selenium.remote.ErrorHandler.throwIfResponseFailed(ErrorHandler.java:156)	at org.openqa.selenium.remote.RemoteWebDriver.execute(RemoteWebDriver.java:599)	at org.openqa.selenium.remote.RemoteWebDriver.get(RemoteWebDriver.java:304)	at org.openqa.selenium.remote.RemoteWebDriver$RemoteNavigation.to(RemoteWebDriver.java:850)	
 Issue 936  has been merged into this issue.
Still having same issue.

Comment 108 Deleted

Comment 109 Deleted

Still having the same issue - the issue being we can't run chrome driver with windows server 2008 R2. A lot of the bugs have been closed as being duplicates but I fear that the "Windows 2008 R2" part of the original bug is getting lost

Still having same issue.
Env:
Windows 2008 R2
Jenkins
Chrome 40
Chrome Driver 2.13
Hi  - I am having a similar same issue with Win8, Chrome 40 and Chromedriver 2.14
Also having this trouble :
Windows 2012 R2
TeamCity 9.0.1
Selenium 2.44
Chrome 40.0.2214.115
ChromeDriver 2.14

Can not find Chrome v37 anymore, so can not retest
Same issue here (I believe):

  [UnknownServerException]                                                                           
  unknown error: Chrome failed to start: exited abnormally                                           
    (Driver info: chromedriver=2.12,platform=Linux 3.17.1 x86_64) (WARNING: The server did not prov  
  ide any stacktrace information)                                                                    
  Command duration or timeout: 60.69 seconds                                                         
  Build info: version: '2.45.0', revision: '5017cb8', time: '2015-02-26 23:59:50'                    
  System info: host: 'lifetree', ip: '127.0.0.1', os.name: 'Linux', os.arch: 'amd64', os.version: '  
  3.17.1', java.version: '1.7.0_76'                                                                  
  Driver info: org.openqa.selenium.chrome.ChromeDriver                               
Seeing a similar issue. We had this issue before (chrome 38 and chromedriver 2.10 I believe), then chrome updated to 39 and the issue went away. Now we're seeing it again on:
Chrome 41.0.2272.76
chromedriver 2.14
Jenkins 1.598

What's strange is everything was working fine for a few days with the versions noted above. Then one evening we started seeing this exception, but ONLY when running the test via Jenkins:

TimeoutException: Message: timeout: Timed out receiving message from renderer: 10.000
  (Session info: chrome=41.0.2272.76)
  (Driver info: chromedriver=2.14.313457 (3d645c400edf2e2c500566c9aa096063e707c9cf),platform=Windows NT 6.3 x86_64)

I have yet to figure out what changed that evening, but so far I'm out of ideas. If I can get some chromedriver logs I will attach them
Is there a fix or workaround for this?  I am pretty sure I am having the same problem and this is blocking us from going forward.

This is a new setup and was not working before and then stopped like most of the other posts.  The tests run just fine if you are a logged on to the server but they fail when run by the TeamCity build agent.  Using the FireFoxDriver works (have not tried IE yet).

Windows Server 2012 R2 Datacenter
TeamCity Professional 9.0.2 (build 32195)
Selenium WebDriver Support 2.45.0
Chrome Version 41.0.2272.89 m
ChromeDriver 2.14.313457
NUnit 2.6.4
SpecFlow 1.9.0.77
.NET 4.5

In the NUnit test I am creating the driver with:
var driver = new ChromeDriver();
driver.Manage().Timeouts().ImplicitlyWait(TimeSpan.FromMilliseconds(2000));

And this is the first thing the test does with the driver that causes the error:
Driver.Navigate().GoToUrl( new Uri( "https://ourtestsite/somepage" ) );

And here is the error:
[MyApplication.Web.Tests.Specification.Features.Accounts.ShowBasicAccountInformationFeature.AnAuthenticatedUserCanSeeTheirAccountName] Test(s) failed. OpenQA.Selenium.WebDriverException : The HTTP request to the remote WebDriver server for URL http://localhost:64730/session/80e37dff3a6381c6c01c227b80d9b11c/url timed out after 60 seconds.
  ----> System.Net.WebException : The operation has timed out
   at OpenQA.Selenium.Remote.HttpCommandExecutor.CreateResponse(WebRequest request)
   at OpenQA.Selenium.Remote.DriverServiceCommandExecutor.Execute(Command commandToExecute)
   at OpenQA.Selenium.Remote.RemoteWebDriver.Execute(String driverCommandToExecute, Dictionary`2 parameters)
   at OpenQA.Selenium.Remote.RemoteWebDriver.get_Url()
   at MyApplication.Web.Tests.Specification.Scenario.Navigate(String url) in c:\BuildAgent\work\cfa7b67f80d179e4\MyApplication.Web.Tests.Specification\Scenario.cs:line 50
   at MyApplication.Web.Tests.Specification.Steps.AuthenticationSteps.GivenIHaveLoggedInAs(String personaName) in c:\BuildAgent\work\cfa7b67f80d179e4\MyApplication.Web.Tests.Specification\Steps\AuthenticationSteps.cs:line 17
   at TechTalk.SpecFlow.Bindings.BindingInvoker.InvokeBinding(IBinding binding, IContextManager contextManager, Object[] arguments, ITestTracer testTracer, TimeSpan& duration)
   at TechTalk.SpecFlow.Infrastructure.TestExecutionEngine.ExecuteStepMatch(BindingMatch match, Object[] arguments)
   at TechTalk.SpecFlow.Infrastructure.TestExecutionEngine.ExecuteStep(StepInstance stepInstance)
   at TechTalk.SpecFlow.Infrastructure.TestExecutionEngine.OnAfterLastStep()
   at MyApplication.Web.Tests.Specification.Features.Accounts.ShowBasicAccountInformationFeature.ScenarioCleanup() in c:\BuildAgent\work\cfa7b67f80d179e4\MyApplication.Web.Tests.Specification\Features\Accounts\RegisteredUserCanLogin.feature.cs:line 0
   at MyApplication.Web.Tests.Specification.Features.Accounts.ShowBasicAccountInformationFeature.AnAuthenticatedUserCanSeeTheirAccountName() in c:\BuildAgent\work\cfa7b67f80d179e4\MyApplication.Web.Tests.Specification\Features\Accounts\RegisteredUserCanLogin.feature:line 9
--WebException
   at System.Net.HttpWebRequest.GetResponse()
   at OpenQA.Selenium.Remote.HttpCommandExecutor.CreateResponse(WebRequest request)

When running the tests when logged onto the server the chrome driver server starts up and shows this in a command window:

Starting ChromeDriver 2.14.313457 (3d645c400edf2e2c500566c9aa096063e707c9cf) on
port 64801
Only local connections are allowed.

I am new to using ChromeDriver so if I figure out how to get more logs I will update this.

Comment 117 Deleted

Comment 118 by tim...@gmail.com, Mar 13 2015

Still doesn't work. I am using Jenkins + 2008 r2 + chrome driver 2.14
Update for #116.  Downgraded Chrome 41/chromedriver 2.14 to Chrome 37.0.2.62.124 and chromedriver 2.12 and our tests are now running fine both locally and from TeamCity.
Hello all,
 I've downgraded Chrome 41 /Chromedriver 2.14 to Chrome 37/chromedriver 2.12 on a Windows Server 2012 Standard; Now, when running the tests through TeamCity 8, I don't get any error message, I think this is because the chrome browser instance doesn't open. Did any of you experience this kind of issue?
Thank you!
Chrome 41.0.2272.76
chromedriver 2.11
Jenkins 1.593
I am seeing this issue for the first time. I will update my chromedriver to 2.12 ands see if this works.

Comment 123 Deleted

Comment 124 Deleted

Comment 125 by imgp...@gmail.com, Apr 20 2015

Hi 
I am getting following error :-
ElementNotVisibleException: Message: element not visible
  (Session info: chrome=42.0.2311.90)
  (Driver info: chromedriver=2.10.267518,platform=Linux 3.13.0-49-generic x86_64)

Please help to sort out this problem

Comment 126 by htin...@gmail.com, May 26 2015

Is there a fix? Still have same issue
All All All
I fixed this bug  by  adding timeout after WebDriver creating.
For me it's 1 second timeout.

WebDriver dr = new ChromeDriver(options);
TimeUnit.SECONDS.sleep(1);

It's works for me.

Please test it.
We are still facing same issue when running our robot framework automation tests through Jenkins,  the chrome browser instance doesn't open in below configurations. Can anybody please help me regarding this issue.

Jenkins 1.617
Windows Server 2012 R2 (64 bit)
chrome=44.0.2403.107
chromedriver=2.16.333243


Please find the below error message:
JavaScript stack:
Error: Failed to capture tab: unknown error
    at checkForExtensionError (chrome-extension://aapnijgdinlhnhlmodcfapnahmbfebeb/background.js:14:17)
    at Object.callback (chrome-extension://aapnijgdinlhnhlmodcfapnahmbfebeb/background.js:37:5)
    at safeCallbackApply (extensions::sendRequest:21:15)
    at handleResponse (extensions::sendRequest:72:7)
  (Session info: chrome=44.0.2403.107)
  (Driver info: chromedriver=2.16.333243 (0bfa1d3575fc1044244f21ddb82bf870944ef961),platform=Windows NT 6.3 x86_64)
Today we we're having some issues with Chrome (wouldn't enter text into some text boxes). We had these versions:
chromedriver: 2.12
Chrome: 44.0.2403.125

I tried updating chromedriver to 2.16, now I'm getting the same old error:
Timed out receiving message from renderer: 600.000

After unsuccessful debugging, I reverted chromedriver back to 2.12. Now the issue is STILL happening. These issues only happen when running the test via Jenkins. At this point I'm chalking it up to be an issue with Jenkins.

The test runs fine locally (on my Mac).
The test runs fine when manually running the test via cmd-line on the Jenkins slave (Windows 8).
Test falls flat on its face when running via Jenkins with the above renderer error.
Facing same issue with chrome

chromeDriver 2.16
Chrome - 44.0
Teamcity 8x
Getting 60 seconds timeout exception, tried adding implicit wait as well, but nothing worked.
Rolled back to chromeDriver version 2.10  - ChromeDriver (v2.10.267521) with chrome browser - 44.0 & Teamcity - 8x, its working fine. 
The issue is only with the new chrome driver 2.16.
To be specific Chromedriver 2.17 and 
beta version of chrome (45.0.2454.26 beta-m (64-bit)) WORKS for me. no need to adding any timeouts or anything. 
Having the same issue...still.

SetUp method failed. SetUp : System.Exception : Browser session was not able to build. See details: System.Net.WebException: The operation has timed out
   at System.Net.HttpWebRequest.GetResponse()
   at OpenQA.Selenium.Remote.HttpCommandExecutor.CreateResponse(WebRequest request). The HTTP request to the remote WebDriver server for URL http://localhost:23323/session timed out after 60 seconds.

ChromeDriver 2.20.0
Selenium.WebDriver 2.48.0
TeamCity 9.1.4 running with NUnit 2.6.4
Chrome Version 46.0.2490.86

Project Member

Comment 134 by gmanikpure@chromium.org, Jan 6 2016

Cc: zt10191...@gmail.com
@zt10191991,
This issue was fixed a long time ago.

If you are still seeing the issue, can you provide your machine configuration details? Original issue was seen specifically on Windows platform. Are you also seeing on Windows only? Does this issue happens only with TeamCity?
Project Member

Comment 135 by gmanikpure@chromium.org, Jan 6 2016

 Issue 936  has been merged into this issue.
I am getting this issue still.

ChromeDriver 2.20.0
Selenium.WebDriver 2.48.0
TeamCity 9.1.4 running with NUnit 2.6.4
Chrome Version 47.0.2526.106 
Project Member

Comment 137 by gmanikpure@chromium.org, Jan 8 2016

Cc: helen.gr...@topcashback.co.uk
@helen.gregory, 
Can you please provide the reproducible test steps? Please attach chromedriver verbose logs.
Also, please answer to my queries in comment#134.
Thanks,
Have the same issue, here is the log from the TeamCity from one of the test(other are the same):
[14:12:34][Volvo.DigitalCommerce.AutomatedTests.dll] Volvo.DigitalCommerce.AutomatedTests.Features.ChildSeat.CS_BaseFlowFeature.CS_GoingThroughFullFlow on Chrome (1m:01s)
[14:13:36][Step 3/3] Starting ChromeDriver 2.21.371459 (36d3d07f660ff2bc1bf28a75d1cdabed0983e7c4) on port 32431
[14:13:36][Step 3/3] Only local connections are allowed.
[14:13:36]
[Volvo.DigitalCommerce.AutomatedTests.Features.ChildSeat.CS_BaseFlowFeature.CS_GoingThroughFullFlow on Chrome] [Test Error Output]
-> warning: The previous ScenarioContext was already disposed.
[14:13:36]
[Volvo.DigitalCommerce.AutomatedTests.Features.ChildSeat.CS_BaseFlowFeature.CS_GoingThroughFullFlow on Chrome] TearDown method failed. Autofac.Core.DependencyResolutionException : An exception was thrown while invoking the constructor 'Void .ctor()' on type 'ChromeDriver'. ---> The HTTP request to the remote WebDriver server for URL http://localhost:32384/session timed out after 60 seconds. (See inner exception for details.)
  ----> OpenQA.Selenium.WebDriverException : The HTTP request to the remote WebDriver server for URL http://localhost:32384/session timed out after 60 seconds.
  ----> System.Net.WebException : The request was aborted: The operation has timed out.
TearDown : System.NullReferenceException : Object reference not set to an instance of an object.
[14:13:36]
[Volvo.DigitalCommerce.AutomatedTests.Features.ChildSeat.CS_BaseFlowFeature.CS_GoingThroughFullFlow on Chrome] TearDown method failed. Autofac.Core.DependencyResolutionException : An exception was thrown while invoking the constructor 'Void .ctor()' on type 'ChromeDriver'. ---> The HTTP request to the remote WebDriver server for URL http://localhost:32384/session timed out after 60 seconds. (See inner exception for details.)
  ----> OpenQA.Selenium.WebDriverException : The HTTP request to the remote WebDriver server for URL http://localhost:32384/session timed out after 60 seconds.
  ----> System.Net.WebException : The request was aborted: The operation has timed out.
TearDown : System.NullReferenceException : Object reference not set to an instance of an object.
   at Autofac.Core.Activators.Reflection.ConstructorParameterBinding.Instantiate()
   at Autofac.Core.Activators.Reflection.ReflectionActivator.ActivateInstance(IComponentContext context, IEnumerable`1 parameters)
   at Autofac.Core.Resolving.InstanceLookup.Activate(IEnumerable`1 parameters)
   at Autofac.Core.Resolving.InstanceLookup.Execute()
   at Autofac.Core.Resolving.ResolveOperation.GetOrCreateInstance(ISharingLifetimeScope currentOperationScope, IComponentRegistration registration, IEnumerable`1 parameters)
   at Autofac.Core.Resolving.ResolveOperation.Execute(IComponentRegistration registration, IEnumerable`1 parameters)
   at Autofac.Core.Lifetime.LifetimeScope.ResolveComponent(IComponentRegistration registration, IEnumerable`1 parameters)
   at Autofac.Core.Container.ResolveComponent(IComponentRegistration registration, IEnumerable`1 parameters)
   at Autofac.ResolutionExtensions.TryResolveService(IComponentContext context, Service service, IEnumerable`1 parameters, Object& instance)
   at Autofac.ResolutionExtensions.ResolveService(IComponentContext context, Service service, IEnumerable`1 parameters)
   at Autofac.ResolutionExtensions.ResolveNamed[TService](IComponentContext context, String serviceName, IEnumerable`1 parameters)
   at Volvo.DigitalCommerce.AutomatedTests.Features.ChildSeat.CS_BaseFlowFeature.CS_GoingThroughFullFlow(String browser) in C:\TeamCity\buildAgent\work\d7512e1031e4b296\Volvo.DigitalCommerce.AutomatedTests\Features\Child Seat\CS_BaseFlow.feature.cs:line 0
--WebDriverException
   at OpenQA.Selenium.Remote.HttpCommandExecutor.CreateResponse(WebRequest request)
   at OpenQA.Selenium.Remote.HttpCommandExecutor.Execute(Command commandToExecute)
   at OpenQA.Selenium.Remote.DriverServiceCommandExecutor.Execute(Command commandToExecute)
   at OpenQA.Selenium.Remote.RemoteWebDriver.Execute(String driverCommandToExecute, Dictionary`2 parameters)
   at OpenQA.Selenium.Remote.RemoteWebDriver.StartSession(ICapabilities desiredCapabilities)
   at OpenQA.Selenium.Remote.RemoteWebDriver..ctor(ICommandExecutor commandExecutor, ICapabilities desiredCapabilities)
   at OpenQA.Selenium.Chrome.ChromeDriver..ctor(ChromeOptions options)
   at lambda_method(Closure , Object[] )
   at Autofac.Core.Activators.Reflection.ConstructorParameterBinding.Instantiate()
--WebException
   at System.Net.HttpWebRequest.GetResponse()
   at OpenQA.Selenium.Remote.HttpCommandExecutor.CreateResponse(WebRequest request)
--TearDown
   at Volvo.DigitalCommerce.AutomatedTests.Features.ChildSeat.CS_BaseFlowFeature.ScenarioTearDown() in C:\TeamCity\buildAgent\work\d7512e1031e4b296\Volvo.DigitalCommerce.AutomatedTests\Features\Child Seat\CS_BaseFlow.feature.cs:line 0

ChromeDriver 2.21.0
Selenium WebDriver 2.53.0
Teamcity 9.1.7
Having same issue here.
Trying to run tests via Octopus and getting following:
Initialization method xxxx.TestInitialize threw exception. OpenQA.Selenium.WebDriverException: OpenQA.Selenium.WebDriverException: The HTTP request to the remote WebDriver server for URL http://localhost:62540/session timed out after 60 seconds. ---&gt; System.Net.WebException: The operation has timed out.
    at System.Net.HttpWebRequest.GetResponse()
   at OpenQA.Selenium.Remote.HttpCommandExecutor.CreateResponse(WebRequest request)
 --- End of inner exception stack trace ---
    at OpenQA.Selenium.Remote.HttpCommandExecutor.CreateResponse(WebRequest request)
   at OpenQA.Selenium.Remote.HttpCommandExecutor.Execute(Command commandToExecute)
   at OpenQA.Selenium.Remote.DriverServiceCommandExecutor.Execute(Command commandToExecute)
   at OpenQA.Selenium.Remote.RemoteWebDriver.Execute(String driverCommandToExecute, Dictionary`2 parameters)
   at OpenQA.Selenium.Remote.RemoteWebDriver.StartSession(ICapabilities desiredCapabilities)
   at OpenQA.Selenium.Remote.RemoteWebDriver..ctor(ICommandExecutor commandExecutor, ICapabilities desiredCapabilities)
   at OpenQA.Selenium.Chrome.ChromeDriver..ctor(ChromeOptions options)
   at xxxxx.TestInitialize() in zzzzzz.cs:line 24

ChromeDriver 2.19.0
Selenium WebDriver 2.53.0
OC Windows 2008 R2
Chrome Version 51.0.2704.106

Interesting point here that tests are failing under NT AUTHORITY\SYSTEM account but work fine for my local user account.
Also they used to pass just few weeks back (on June 3rd) with exactly same code.
May be Chrome issue.

I found fix here https://bugs.chromium.org/p/chromedriver/issues/detail?id=1389 that worked for me:
chromeOptions.AddArguments("no-sandbox");
Thank you, have had same problem after a chrome update from 51.0.2704.103 to 52.0.2743.116, adding no-sandbox has resolved this when running our tests through task scheduler
Project Member

Comment 142 by gmanikpure@chromium.org, Aug 10 2016

Status: Fixed (was: Duplicate)
Fix is available in canary channel you shouldn't need to pass --no-sandbox.
Please see https://bugs.chromium.org/p/chromedriver/issues/detail?id=1389#c25

Comment 143 Deleted

Comment 144 Deleted

Issue: fixed

Use the latest chrome version and the issue will be solved. You can always download the latest chrome version from here https://sites.google.com/a/chromium.org/chromedriver/downloads
Showing comments 46 - 145 of 145 Older

Sign in to add a comment